296a038de9
SVN-Revision: 12859
61 lines
1.6 KiB
Diff
61 lines
1.6 KiB
Diff
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -577,6 +577,13 @@
|
|
#
|
|
core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
|
|
|
|
+#
|
|
+# Atheros AR71xx
|
|
+#
|
|
+core-$(CONFIG_ATHEROS_AR71XX) += arch/mips/ar71xx/
|
|
+cflags-$(CONFIG_ATHEROS_AR71XX) += -Iinclude/asm-mips/mach-ar71xx
|
|
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
|
+
|
|
# temporary until string.h is fixed
|
|
cflags-y += -ffreestanding
|
|
|
|
--- a/include/asm-mips/bootinfo.h
|
|
+++ b/include/asm-mips/bootinfo.h
|
|
@@ -57,6 +57,15 @@
|
|
#define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
|
|
#define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
|
|
|
|
+/*
|
|
+ * Valid machtype for Atheros AR71xx based boards
|
|
+ */
|
|
+#define MACH_AR71XX_GENERIC 0
|
|
+#define MACH_AR71XX_WP543 1 /* Compex WP543 */
|
|
+#define MACH_AR71XX_RB_411 2 /* MikroTik RouterBOARD 411 */
|
|
+#define MACH_AR71XX_RB_433 3 /* MikroTik RouterBOARD 433/433AH */
|
|
+#define MACH_AR71XX_RB_450 4 /* MikroTik RouterBOARD 450 */
|
|
+
|
|
#define CL_SIZE COMMAND_LINE_SIZE
|
|
|
|
extern char *system_type;
|
|
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -22,6 +22,23 @@
|
|
config MACH_ALCHEMY
|
|
bool "Alchemy processor based machines"
|
|
|
|
+config ATHEROS_AR71XX
|
|
+ bool "Atheros AR71xx based boards"
|
|
+ select CEVT_R4K
|
|
+ select CSRC_R4K
|
|
+ select DMA_NONCOHERENT
|
|
+ select HW_HAS_PCI
|
|
+ select IRQ_CPU
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select SYS_HAS_CPU_MIPS32_R1
|
|
+ select SYS_HAS_CPU_MIPS32_R2
|
|
+ select SYS_SUPPORTS_32BIT_KERNEL
|
|
+ select SYS_SUPPORTS_BIG_ENDIAN
|
|
+ select SYS_HAS_EARLY_PRINTK
|
|
+ select MIPS_MACHINE
|
|
+ help
|
|
+ Support for Atheros AR71xx based boards.
|
|
+
|
|
config BASLER_EXCITE
|
|
bool "Basler eXcite smart camera"
|
|
select CEVT_R4K
|