1e5b7c17b0
Based on patch by Bryan Forbes <bryan@reigndropsfall.net> Also update mt76 to update for API changes Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44655
15 lines
633 B
Diff
15 lines
633 B
Diff
--- a/kconf/Makefile
|
|
+++ b/kconf/Makefile
|
|
@@ -1,9 +1,9 @@
|
|
-CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
|
|
+CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -DKBUILD_NO_NLS
|
|
|
|
LXDIALOG := lxdialog/checklist.o lxdialog/inputbox.o lxdialog/menubox.o lxdialog/textbox.o lxdialog/util.o lxdialog/yesno.o
|
|
|
|
conf: conf.o zconf.tab.o
|
|
-mconf_CFLAGS := $(shell ./lxdialog/check-lxdialog.sh -ccflags) -DLOCALE
|
|
+mconf_CFLAGS := $(shell ./lxdialog/check-lxdialog.sh -ccflags)
|
|
mconf_LDFLAGS := $(shell ./lxdialog/check-lxdialog.sh -ldflags $(CC))
|
|
mconf: CFLAGS += $(mconf_CFLAGS)
|
|
|