ec3ee0969e
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47286
377 lines
11 KiB
Diff
377 lines
11 KiB
Diff
--- a/net/mac80211/Kconfig
|
|
+++ b/net/mac80211/Kconfig
|
|
@@ -5,8 +5,6 @@ config MAC80211
|
|
depends on CRYPTO
|
|
depends on CRYPTO_ARC4
|
|
depends on CRYPTO_AES
|
|
- select BPAUTO_CRYPTO_CCM
|
|
- depends on CRYPTO_GCM
|
|
depends on CRC32
|
|
---help---
|
|
This option enables the hardware independent IEEE 802.11
|
|
--- a/net/mac80211/Makefile
|
|
+++ b/net/mac80211/Makefile
|
|
@@ -16,9 +16,7 @@ mac80211-y := \
|
|
michael.o \
|
|
tkip.o \
|
|
aes_ccm.o \
|
|
- aes_gcm.o \
|
|
aes_cmac.o \
|
|
- aes_gmac.o \
|
|
cfg.o \
|
|
ethtool.o \
|
|
rx.o \
|
|
--- a/net/mac80211/aes_ccm.c
|
|
+++ b/net/mac80211/aes_ccm.c
|
|
@@ -13,89 +13,132 @@
|
|
#include <linux/types.h>
|
|
#include <linux/err.h>
|
|
#include <crypto/aead.h>
|
|
+#include <crypto/aes.h>
|
|
|
|
#include <net/mac80211.h>
|
|
#include "key.h"
|
|
#include "aes_ccm.h"
|
|
|
|
-void ieee80211_aes_ccm_encrypt(struct crypto_aead *tfm, u8 *b_0, u8 *aad,
|
|
- u8 *data, size_t data_len, u8 *mic,
|
|
- size_t mic_len)
|
|
+static void aes_ccm_prepare(struct crypto_cipher *tfm, u8 *b_0, u8 *aad, u8 *s_0,
|
|
+ u8 *a, u8 *b)
|
|
{
|
|
- struct scatterlist sg[3];
|
|
+ int i;
|
|
+
|
|
+ crypto_cipher_encrypt_one(tfm, b, b_0);
|
|
+
|
|
+ /* Extra Authenticate-only data (always two AES blocks) */
|
|
+ for (i = 0; i < AES_BLOCK_SIZE; i++)
|
|
+ aad[i] ^= b[i];
|
|
+ crypto_cipher_encrypt_one(tfm, b, aad);
|
|
+
|
|
+ aad += AES_BLOCK_SIZE;
|
|
+
|
|
+ for (i = 0; i < AES_BLOCK_SIZE; i++)
|
|
+ aad[i] ^= b[i];
|
|
+ crypto_cipher_encrypt_one(tfm, a, aad);
|
|
|
|
- char aead_req_data[sizeof(struct aead_request) +
|
|
- crypto_aead_reqsize(tfm)]
|
|
- __aligned(__alignof__(struct aead_request));
|
|
- struct aead_request *aead_req = (void *) aead_req_data;
|
|
+ /* Mask out bits from auth-only-b_0 */
|
|
+ b_0[0] &= 0x07;
|
|
|
|
- memset(aead_req, 0, sizeof(aead_req_data));
|
|
+ /* S_0 is used to encrypt T (= MIC) */
|
|
+ b_0[14] = 0;
|
|
+ b_0[15] = 0;
|
|
+ crypto_cipher_encrypt_one(tfm, s_0, b_0);
|
|
+}
|
|
|
|
- sg_init_table(sg, 3);
|
|
- sg_set_buf(&sg[0], &aad[2], be16_to_cpup((__be16 *)aad));
|
|
- sg_set_buf(&sg[1], data, data_len);
|
|
- sg_set_buf(&sg[2], mic, mic_len);
|
|
|
|
- aead_request_set_tfm(aead_req, tfm);
|
|
- aead_request_set_crypt(aead_req, sg, sg, data_len, b_0);
|
|
- aead_request_set_ad(aead_req, sg[0].length);
|
|
+void ieee80211_aes_ccm_encrypt(struct crypto_cipher *tfm, u8 *b_0, u8 *aad,
|
|
+ u8 *data, size_t data_len, u8 *mic,
|
|
+ size_t mic_len)
|
|
+{
|
|
+ int i, j, last_len, num_blocks;
|
|
+ u8 b[AES_BLOCK_SIZE];
|
|
+ u8 s_0[AES_BLOCK_SIZE];
|
|
+ u8 e[AES_BLOCK_SIZE];
|
|
+ u8 *pos, *cpos;
|
|
+
|
|
+ num_blocks = DIV_ROUND_UP(data_len, AES_BLOCK_SIZE);
|
|
+ last_len = data_len % AES_BLOCK_SIZE;
|
|
+ aes_ccm_prepare(tfm, b_0, aad, s_0, b, b);
|
|
+
|
|
+ /* Process payload blocks */
|
|
+ pos = data;
|
|
+ cpos = data;
|
|
+ for (j = 1; j <= num_blocks; j++) {
|
|
+ int blen = (j == num_blocks && last_len) ?
|
|
+ last_len : AES_BLOCK_SIZE;
|
|
+
|
|
+ /* Authentication followed by encryption */
|
|
+ for (i = 0; i < blen; i++)
|
|
+ b[i] ^= pos[i];
|
|
+ crypto_cipher_encrypt_one(tfm, b, b);
|
|
+
|
|
+ b_0[14] = (j >> 8) & 0xff;
|
|
+ b_0[15] = j & 0xff;
|
|
+ crypto_cipher_encrypt_one(tfm, e, b_0);
|
|
+ for (i = 0; i < blen; i++)
|
|
+ *cpos++ = *pos++ ^ e[i];
|
|
+ }
|
|
|
|
- crypto_aead_encrypt(aead_req);
|
|
+ for (i = 0; i < mic_len; i++)
|
|
+ mic[i] = b[i] ^ s_0[i];
|
|
}
|
|
|
|
-int ieee80211_aes_ccm_decrypt(struct crypto_aead *tfm, u8 *b_0, u8 *aad,
|
|
+int ieee80211_aes_ccm_decrypt(struct crypto_cipher *tfm, u8 *b_0, u8 *aad,
|
|
u8 *data, size_t data_len, u8 *mic,
|
|
size_t mic_len)
|
|
{
|
|
- struct scatterlist sg[3];
|
|
- char aead_req_data[sizeof(struct aead_request) +
|
|
- crypto_aead_reqsize(tfm)]
|
|
- __aligned(__alignof__(struct aead_request));
|
|
- struct aead_request *aead_req = (void *) aead_req_data;
|
|
-
|
|
- if (data_len == 0)
|
|
- return -EINVAL;
|
|
-
|
|
- memset(aead_req, 0, sizeof(aead_req_data));
|
|
-
|
|
- sg_init_table(sg, 3);
|
|
- sg_set_buf(&sg[0], &aad[2], be16_to_cpup((__be16 *)aad));
|
|
- sg_set_buf(&sg[1], data, data_len);
|
|
- sg_set_buf(&sg[2], mic, mic_len);
|
|
-
|
|
- aead_request_set_tfm(aead_req, tfm);
|
|
- aead_request_set_crypt(aead_req, sg, sg, data_len + mic_len, b_0);
|
|
- aead_request_set_ad(aead_req, sg[0].length);
|
|
+ int i, j, last_len, num_blocks;
|
|
+ u8 *pos, *cpos;
|
|
+ u8 a[AES_BLOCK_SIZE];
|
|
+ u8 b[AES_BLOCK_SIZE];
|
|
+ u8 s_0[AES_BLOCK_SIZE];
|
|
+
|
|
+ num_blocks = DIV_ROUND_UP(data_len, AES_BLOCK_SIZE);
|
|
+ last_len = data_len % AES_BLOCK_SIZE;
|
|
+ aes_ccm_prepare(tfm, b_0, aad, s_0, a, b);
|
|
+
|
|
+ /* Process payload blocks */
|
|
+ cpos = data;
|
|
+ pos = data;
|
|
+ for (j = 1; j <= num_blocks; j++) {
|
|
+ int blen = (j == num_blocks && last_len) ?
|
|
+ last_len : AES_BLOCK_SIZE;
|
|
+
|
|
+ /* Decryption followed by authentication */
|
|
+ b_0[14] = (j >> 8) & 0xff;
|
|
+ b_0[15] = j & 0xff;
|
|
+ crypto_cipher_encrypt_one(tfm, b, b_0);
|
|
+ for (i = 0; i < blen; i++) {
|
|
+ *pos = *cpos++ ^ b[i];
|
|
+ a[i] ^= *pos++;
|
|
+ }
|
|
+ crypto_cipher_encrypt_one(tfm, a, a);
|
|
+ }
|
|
+
|
|
+ for (i = 0; i < mic_len; i++) {
|
|
+ if ((mic[i] ^ s_0[i]) != a[i])
|
|
+ return -1;
|
|
+ }
|
|
|
|
- return crypto_aead_decrypt(aead_req);
|
|
+ return 0;
|
|
}
|
|
|
|
-struct crypto_aead *ieee80211_aes_key_setup_encrypt(const u8 key[],
|
|
- size_t key_len,
|
|
- size_t mic_len)
|
|
+struct crypto_cipher *ieee80211_aes_key_setup_encrypt(const u8 key[],
|
|
+ size_t key_len,
|
|
+ size_t mic_len)
|
|
{
|
|
- struct crypto_aead *tfm;
|
|
- int err;
|
|
+ struct crypto_cipher *tfm;
|
|
|
|
- tfm = crypto_alloc_aead("ccm(aes)", 0, CRYPTO_ALG_ASYNC);
|
|
- if (IS_ERR(tfm))
|
|
- return tfm;
|
|
-
|
|
- err = crypto_aead_setkey(tfm, key, key_len);
|
|
- if (err)
|
|
- goto free_aead;
|
|
- err = crypto_aead_setauthsize(tfm, mic_len);
|
|
- if (err)
|
|
- goto free_aead;
|
|
+ tfm = crypto_alloc_cipher("aes", 0, CRYPTO_ALG_ASYNC);
|
|
+ if (!IS_ERR(tfm))
|
|
+ crypto_cipher_setkey(tfm, key, key_len);
|
|
|
|
return tfm;
|
|
-
|
|
-free_aead:
|
|
- crypto_free_aead(tfm);
|
|
- return ERR_PTR(err);
|
|
}
|
|
|
|
-void ieee80211_aes_key_free(struct crypto_aead *tfm)
|
|
+
|
|
+void ieee80211_aes_key_free(struct crypto_cipher *tfm)
|
|
{
|
|
- crypto_free_aead(tfm);
|
|
+ crypto_free_cipher(tfm);
|
|
}
|
|
--- a/net/mac80211/aes_ccm.h
|
|
+++ b/net/mac80211/aes_ccm.h
|
|
@@ -12,15 +12,15 @@
|
|
|
|
#include <linux/crypto.h>
|
|
|
|
-struct crypto_aead *ieee80211_aes_key_setup_encrypt(const u8 key[],
|
|
- size_t key_len,
|
|
- size_t mic_len);
|
|
-void ieee80211_aes_ccm_encrypt(struct crypto_aead *tfm, u8 *b_0, u8 *aad,
|
|
+struct crypto_cipher *ieee80211_aes_key_setup_encrypt(const u8 key[],
|
|
+ size_t key_len,
|
|
+ size_t mic_len);
|
|
+void ieee80211_aes_ccm_encrypt(struct crypto_cipher *tfm, u8 *b_0, u8 *aad,
|
|
u8 *data, size_t data_len, u8 *mic,
|
|
size_t mic_len);
|
|
-int ieee80211_aes_ccm_decrypt(struct crypto_aead *tfm, u8 *b_0, u8 *aad,
|
|
+int ieee80211_aes_ccm_decrypt(struct crypto_cipher *tfm, u8 *b_0, u8 *aad,
|
|
u8 *data, size_t data_len, u8 *mic,
|
|
size_t mic_len);
|
|
-void ieee80211_aes_key_free(struct crypto_aead *tfm);
|
|
+void ieee80211_aes_key_free(struct crypto_cipher *tfm);
|
|
|
|
#endif /* AES_CCM_H */
|
|
--- a/net/mac80211/aes_gcm.h
|
|
+++ b/net/mac80211/aes_gcm.h
|
|
@@ -11,12 +11,28 @@
|
|
|
|
#include <linux/crypto.h>
|
|
|
|
-void ieee80211_aes_gcm_encrypt(struct crypto_aead *tfm, u8 *j_0, u8 *aad,
|
|
- u8 *data, size_t data_len, u8 *mic);
|
|
-int ieee80211_aes_gcm_decrypt(struct crypto_aead *tfm, u8 *j_0, u8 *aad,
|
|
- u8 *data, size_t data_len, u8 *mic);
|
|
-struct crypto_aead *ieee80211_aes_gcm_key_setup_encrypt(const u8 key[],
|
|
- size_t key_len);
|
|
-void ieee80211_aes_gcm_key_free(struct crypto_aead *tfm);
|
|
+static inline void
|
|
+ieee80211_aes_gcm_encrypt(struct crypto_aead *tfm, u8 *j_0, u8 *aad,
|
|
+ u8 *data, size_t data_len, u8 *mic)
|
|
+{
|
|
+}
|
|
+
|
|
+static inline int
|
|
+ieee80211_aes_gcm_decrypt(struct crypto_aead *tfm, u8 *j_0, u8 *aad,
|
|
+ u8 *data, size_t data_len, u8 *mic)
|
|
+{
|
|
+ return -EOPNOTSUPP;
|
|
+}
|
|
+
|
|
+static inline struct crypto_aead *
|
|
+ieee80211_aes_gcm_key_setup_encrypt(const u8 key[], size_t key_len)
|
|
+{
|
|
+ return NULL;
|
|
+}
|
|
+
|
|
+static inline void
|
|
+ieee80211_aes_gcm_key_free(struct crypto_aead *tfm)
|
|
+{
|
|
+}
|
|
|
|
#endif /* AES_GCM_H */
|
|
--- a/net/mac80211/aes_gmac.h
|
|
+++ b/net/mac80211/aes_gmac.h
|
|
@@ -11,10 +11,22 @@
|
|
|
|
#include <linux/crypto.h>
|
|
|
|
-struct crypto_aead *ieee80211_aes_gmac_key_setup(const u8 key[],
|
|
- size_t key_len);
|
|
-int ieee80211_aes_gmac(struct crypto_aead *tfm, const u8 *aad, u8 *nonce,
|
|
- const u8 *data, size_t data_len, u8 *mic);
|
|
-void ieee80211_aes_gmac_key_free(struct crypto_aead *tfm);
|
|
+static inline struct crypto_aead *
|
|
+ieee80211_aes_gmac_key_setup(const u8 key[], size_t key_len)
|
|
+{
|
|
+ return NULL;
|
|
+}
|
|
+
|
|
+static inline int
|
|
+ieee80211_aes_gmac(struct crypto_aead *tfm, const u8 *aad, u8 *nonce,
|
|
+ const u8 *data, size_t data_len, u8 *mic)
|
|
+{
|
|
+ return -EOPNOTSUPP;
|
|
+}
|
|
+
|
|
+static inline void
|
|
+ieee80211_aes_gmac_key_free(struct crypto_aead *tfm)
|
|
+{
|
|
+}
|
|
|
|
#endif /* AES_GMAC_H */
|
|
--- a/net/mac80211/key.h
|
|
+++ b/net/mac80211/key.h
|
|
@@ -84,7 +84,7 @@ struct ieee80211_key {
|
|
* Management frames.
|
|
*/
|
|
u8 rx_pn[IEEE80211_NUM_TIDS + 1][IEEE80211_CCMP_PN_LEN];
|
|
- struct crypto_aead *tfm;
|
|
+ struct crypto_cipher *tfm;
|
|
u32 replays; /* dot11RSNAStatsCCMPReplays */
|
|
} ccmp;
|
|
struct {
|
|
--- a/net/mac80211/wpa.c
|
|
+++ b/net/mac80211/wpa.c
|
|
@@ -307,7 +307,8 @@ ieee80211_crypto_tkip_decrypt(struct iee
|
|
}
|
|
|
|
|
|
-static void ccmp_special_blocks(struct sk_buff *skb, u8 *pn, u8 *b_0, u8 *aad)
|
|
+static void ccmp_special_blocks(struct sk_buff *skb, u8 *pn, u8 *b_0, u8 *aad,
|
|
+ u16 data_len)
|
|
{
|
|
__le16 mask_fc;
|
|
int a4_included, mgmt;
|
|
@@ -337,14 +338,8 @@ static void ccmp_special_blocks(struct s
|
|
else
|
|
qos_tid = 0;
|
|
|
|
- /* In CCM, the initial vectors (IV) used for CTR mode encryption and CBC
|
|
- * mode authentication are not allowed to collide, yet both are derived
|
|
- * from this vector b_0. We only set L := 1 here to indicate that the
|
|
- * data size can be represented in (L+1) bytes. The CCM layer will take
|
|
- * care of storing the data length in the top (L+1) bytes and setting
|
|
- * and clearing the other bits as is required to derive the two IVs.
|
|
- */
|
|
- b_0[0] = 0x1;
|
|
+ /* First block, b_0 */
|
|
+ b_0[0] = 0x59; /* flags: Adata: 1, M: 011, L: 001 */
|
|
|
|
/* Nonce: Nonce Flags | A2 | PN
|
|
* Nonce Flags: Priority (b0..b3) | Management (b4) | Reserved (b5..b7)
|
|
@@ -352,6 +347,8 @@ static void ccmp_special_blocks(struct s
|
|
b_0[1] = qos_tid | (mgmt << 4);
|
|
memcpy(&b_0[2], hdr->addr2, ETH_ALEN);
|
|
memcpy(&b_0[8], pn, IEEE80211_CCMP_PN_LEN);
|
|
+ /* l(m) */
|
|
+ put_unaligned_be16(data_len, &b_0[14]);
|
|
|
|
/* AAD (extra authenticate-only data) / masked 802.11 header
|
|
* FC | A1 | A2 | A3 | SC | [A4] | [QC] */
|
|
@@ -463,7 +460,7 @@ static int ccmp_encrypt_skb(struct ieee8
|
|
return 0;
|
|
|
|
pos += IEEE80211_CCMP_HDR_LEN;
|
|
- ccmp_special_blocks(skb, pn, b_0, aad);
|
|
+ ccmp_special_blocks(skb, pn, b_0, aad, len);
|
|
ieee80211_aes_ccm_encrypt(key->u.ccmp.tfm, b_0, aad, pos, len,
|
|
skb_put(skb, mic_len), mic_len);
|
|
|
|
@@ -534,7 +531,7 @@ ieee80211_crypto_ccmp_decrypt(struct iee
|
|
u8 aad[2 * AES_BLOCK_SIZE];
|
|
u8 b_0[AES_BLOCK_SIZE];
|
|
/* hardware didn't decrypt/verify MIC */
|
|
- ccmp_special_blocks(skb, pn, b_0, aad);
|
|
+ ccmp_special_blocks(skb, pn, b_0, aad, data_len);
|
|
|
|
if (ieee80211_aes_ccm_decrypt(
|
|
key->u.ccmp.tfm, b_0, aad,
|