33 lines
914 B
Diff
33 lines
914 B
Diff
--- a/arch/powerpc/platforms/44x/Makefile
|
|
+++ b/arch/powerpc/platforms/44x/Makefile
|
|
@@ -4,6 +4,7 @@ ifneq ($(CONFIG_PPC4xx_CPM),y)
|
|
obj-y += idle.o
|
|
endif
|
|
obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
|
|
+obj-$(CONFIG_WNDR4700) += wndr4700.o
|
|
obj-$(CONFIG_EBONY) += ebony.o
|
|
obj-$(CONFIG_SAM440EP) += sam440ep.o
|
|
obj-$(CONFIG_WARP) += warp.o
|
|
--- a/arch/powerpc/platforms/44x/Kconfig
|
|
+++ b/arch/powerpc/platforms/44x/Kconfig
|
|
@@ -260,6 +260,19 @@ config ICON
|
|
help
|
|
This option enables support for the AMCC PPC440SPe evaluation board.
|
|
|
|
+config WNDR4700
|
|
+ bool "WNDR4700"
|
|
+ depends on 44x
|
|
+ default n
|
|
+ select APM821xx
|
|
+ select PCI_MSI
|
|
+ select PPC4xx_MSI
|
|
+ select PPC4xx_PCI_EXPRESS
|
|
+ select IBM_EMAC_RGMII
|
|
+ select 460EX
|
|
+ help
|
|
+ This option enables support for the Netgear WNDR4700/WNDR4720 board.
|
|
+
|
|
config XILINX_VIRTEX440_GENERIC_BOARD
|
|
bool "Generic Xilinx Virtex 5 FXT board support"
|
|
depends on 44x
|