6a7100c760
Fixes the following issues: [ 7.660000] regmap_core: module license 'unspecified' taints kernel [ 7.690000] Disabling lock debugging due to kernel [ 7.700000] regmap_core: Unknown symbol lzo1x_decompress_safe (err 0 [ 7.710000] regmap_core: Unknown symbol lzo1x_1_compress (err 0 [ 7.720000] regmap_core: Unknown symbol devres_add (err 0 [ 7.730000] regmap_core: Unknown symbol debugfs_create_bool (err 0 [ 7.750000] regmap_core: Unknown symbol devres_alloc (err 0 [ 7.760000] regmap_core: Unknown symbol debugfs_remove_recursive (err 0 [ 7.770000] regmap_core: Unknown symbol debugfs_create_file (err 0 [ 7.780000] regmap_core: Unknown symbol devres_free (err 0 [ 7.800000] regmap_core: Unknown symbol devres_find (err 0 [ 7.810000] regmap_core: Unknown symbol debugfs_create_dir (err 0) Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36070
68 lines
1.6 KiB
Diff
68 lines
1.6 KiB
Diff
--- a/drivers/base/regmap/Kconfig
|
|
+++ b/drivers/base/regmap/Kconfig
|
|
@@ -3,19 +3,21 @@
|
|
# subsystems should select the appropriate symbols.
|
|
|
|
config REGMAP
|
|
- default y if (REGMAP_I2C || REGMAP_SPI)
|
|
select LZO_COMPRESS
|
|
select LZO_DECOMPRESS
|
|
select IRQ_DOMAIN if REGMAP_IRQ
|
|
- bool
|
|
+ tristate
|
|
|
|
config REGMAP_I2C
|
|
+ select REGMAP
|
|
tristate
|
|
|
|
config REGMAP_SPI
|
|
+ select REGMAP
|
|
tristate
|
|
|
|
config REGMAP_MMIO
|
|
+ select REGMAP
|
|
tristate
|
|
|
|
config REGMAP_IRQ
|
|
--- a/include/linux/regmap.h
|
|
+++ b/include/linux/regmap.h
|
|
@@ -43,7 +43,7 @@ struct reg_default {
|
|
unsigned int def;
|
|
};
|
|
|
|
-#ifdef CONFIG_REGMAP
|
|
+#if IS_ENABLED(CONFIG_REGMAP)
|
|
|
|
enum regmap_endian {
|
|
/* Unspecified -> 0 -> Backwards compatible default */
|
|
--- a/drivers/base/regmap/Makefile
|
|
+++ b/drivers/base/regmap/Makefile
|
|
@@ -1,6 +1,8 @@
|
|
-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
|
|
-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o
|
|
-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
|
|
+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o
|
|
+ifdef CONFIG_DEBUG_FS
|
|
+regmap-core-objs += regmap-debugfs.o
|
|
+endif
|
|
+obj-$(CONFIG_REGMAP) += regmap-core.o
|
|
obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
|
|
obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
|
|
obj-$(CONFIG_REGMAP_MMIO) += regmap-mmio.o
|
|
--- a/drivers/base/regmap/regmap.c
|
|
+++ b/drivers/base/regmap/regmap.c
|
|
@@ -13,6 +13,7 @@
|
|
#include <linux/device.h>
|
|
#include <linux/slab.h>
|
|
#include <linux/export.h>
|
|
+#include <linux/module.h>
|
|
#include <linux/mutex.h>
|
|
#include <linux/err.h>
|
|
#include <linux/rbtree.h>
|
|
@@ -1418,3 +1419,5 @@ static int __init regmap_initcall(void)
|
|
return 0;
|
|
}
|
|
postcore_initcall(regmap_initcall);
|
|
+
|
|
+MODULE_LICENSE("GPL");
|