f529a37420
SVN-Revision: 11894
62 lines
1.7 KiB
Diff
62 lines
1.7 KiB
Diff
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -593,6 +593,13 @@
|
|
cflags-$(CONFIG_TOSHIBA_RBTX4938) += -Iinclude/asm-mips/mach-tx49xx
|
|
load-$(CONFIG_TOSHIBA_RBTX4938) += 0xffffffff80100000
|
|
|
|
+#
|
|
+# Atheros AR71xx
|
|
+#
|
|
+core-$(CONFIG_ATHEROS_AR71XX) += arch/mips/ar71xx/
|
|
+cflags-$(CONFIG_ATHEROS_AR71XX) += -Iinclude/asm-mips/mach-ar71xx
|
|
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
|
+
|
|
# temporary until string.h is fixed
|
|
cflags-y += -ffreestanding
|
|
|
|
--- a/include/asm-mips/bootinfo.h
|
|
+++ b/include/asm-mips/bootinfo.h
|
|
@@ -79,6 +79,15 @@
|
|
#define MACH_LASAT_200 1 /* Masquerade PRO/SP200 */
|
|
|
|
/*
|
|
+ * Valid machtype for Atheros AR71xx based boards
|
|
+ */
|
|
+#define MACH_AR71XX_GENERIC 0
|
|
+#define MACH_AR71XX_WP543 1 /* Compex WP543 */
|
|
+#define MACH_AR71XX_RB_411 2 /* MikroTik RouterBOARD 411 */
|
|
+#define MACH_AR71XX_RB_433 3 /* MikroTik RouterBOARD 433/433AH */
|
|
+#define MACH_AR71XX_RB_450 4 /* MikroTik RouterBOARD 450 */
|
|
+
|
|
+/*
|
|
* Valid machtype for group NEC EMMA2RH
|
|
*/
|
|
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
|
|
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -21,6 +21,24 @@
|
|
config MACH_ALCHEMY
|
|
bool "Alchemy processor based machines"
|
|
|
|
+config ATHEROS_AR71XX
|
|
+ bool "Atheros AR71xx based boards"
|
|
+ select CEVT_R4K
|
|
+ select CSRC_R4K
|
|
+ select DMA_NONCOHERENT
|
|
+ select HW_HAS_PCI
|
|
+ select IRQ_CPU
|
|
+ select GENERIC_GPIO
|
|
+ select HAVE_GPIO_LIB
|
|
+ select SYS_HAS_CPU_MIPS32_R1
|
|
+ select SYS_HAS_CPU_MIPS32_R2
|
|
+ select SYS_SUPPORTS_32BIT_KERNEL
|
|
+ select SYS_SUPPORTS_BIG_ENDIAN
|
|
+ select SYS_HAS_EARLY_PRINTK
|
|
+ select MIPS_MACHINE
|
|
+ help
|
|
+ Support for Atheros AR71xx based boards.
|
|
+
|
|
config BASLER_EXCITE
|
|
bool "Basler eXcite smart camera"
|
|
select CEVT_R4K
|