27dee35f99
SVN-Revision: 14451
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
--- a/drivers/net/Kconfig
|
|
+++ b/drivers/net/Kconfig
|
|
@@ -1449,6 +1449,24 @@ config APRICOT
|
|
To compile this driver as a module, choose M here. The module
|
|
will be called apricot.
|
|
|
|
+config R6040
|
|
+ tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
|
|
+ depends on NET_PCI && EXPERIMENTAL
|
|
+ select MII
|
|
+ help
|
|
+ If you have a network (Ethernet) controller of this type, say Y and
|
|
+ read the Ethernet-HOWTO, available from
|
|
+ <http://www.tldp.org/docs.html#howto>.
|
|
+
|
|
+ To compile this driver as a module, choose M here and read
|
|
+ <file:Documentation/networking/net-modules.txt>. The module will be
|
|
+ called r6040.
|
|
+
|
|
+
|
|
+config R6040_NAPI
|
|
+ bool "NAPI support for R6040"
|
|
+ depends on R6040
|
|
+ default y
|
|
config B44
|
|
tristate "Broadcom 440x/47xx ethernet support"
|
|
depends on SSB_POSSIBLE
|
|
--- a/drivers/net/Makefile
|
|
+++ b/drivers/net/Makefile
|
|
@@ -116,6 +116,7 @@ obj-$(CONFIG_LNE390) += lne390.o 8390.o
|
|
obj-$(CONFIG_NE3210) += ne3210.o 8390.o
|
|
obj-$(CONFIG_SB1250_MAC) += sb1250-mac.o
|
|
obj-$(CONFIG_B44) += b44.o
|
|
+obj-$(CONFIG_R6040) += r6040.o
|
|
obj-$(CONFIG_FORCEDETH) += forcedeth.o
|
|
obj-$(CONFIG_NE_H8300) += ne-h8300.o
|
|
obj-$(CONFIG_AX88796) += ax88796.o
|