34d362d1a7
SVN-Revision: 11631
43 lines
1.6 KiB
Diff
43 lines
1.6 KiB
Diff
Index: linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
|
|
===================================================================
|
|
--- linux-2.6.22.19.orig/drivers/mtd/devices/at91_dataflash.c
|
|
+++ linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
|
|
@@ -175,7 +175,7 @@ static struct mtd_partition static_parti
|
|
};
|
|
#endif
|
|
|
|
-static const char *part_probes[] = { "cmdlinepart", NULL, };
|
|
+static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
|
|
|
|
#endif
|
|
|
|
Index: linux-2.6.22.19/drivers/mtd/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.22.19.orig/drivers/mtd/Kconfig
|
|
+++ linux-2.6.22.19/drivers/mtd/Kconfig
|
|
@@ -168,6 +168,12 @@ config MTD_AFS_PARTS
|
|
the partition map from the children of the flash node,
|
|
as described in Documentation/powerpc/booting-without-of.txt.
|
|
|
|
+config MTD_AT91_PARTS
|
|
+ tristate "Atmel AT91 partitioning support"
|
|
+ depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
|
|
+ ---help---
|
|
+ Atmel AT91 partitioning support
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
Index: linux-2.6.22.19/drivers/mtd/Makefile
|
|
===================================================================
|
|
--- linux-2.6.22.19.orig/drivers/mtd/Makefile
|
|
+++ linux-2.6.22.19/drivers/mtd/Makefile
|
|
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
+obj-$(CONFIG_MTD_AT91_PARTS) += at91part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|