2552e9319e
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
134 lines
3.0 KiB
Diff
134 lines
3.0 KiB
Diff
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Netgear R8500
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm47094-netgear-r8500.dts | 31 ++++++++++++++++++++++++++++
|
|
2 files changed, 32 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -79,6 +79,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm4709-netgear-r7900.dtb \
|
|
bcm4709-netgear-r8000.dtb \
|
|
bcm47094-dlink-dir-885l.dtb \
|
|
+ bcm47094-netgear-r8500.dtb \
|
|
bcm47189-tenda-ac9.dtb \
|
|
bcm94708.dtb \
|
|
bcm94709.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
|
@@ -0,0 +1,107 @@
|
|
+/*
|
|
+ * Broadcom BCM470X / BCM5301X ARM platform code.
|
|
+ * DTS for Netgear R8500
|
|
+ *
|
|
+ * Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
|
|
+ *
|
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm4708.dtsi"
|
|
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "netgear,r8500", "brcm,bcm47094", "brcm,bcm4708";
|
|
+ model = "Netgear R8500";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x08000000>;
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ power0 {
|
|
+ label = "bcm53xx:white:power";
|
|
+ gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ power1 {
|
|
+ label = "bcm53xx:amber:power";
|
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ 5ghz-1 {
|
|
+ label = "bcm53xx:white:5ghz-1";
|
|
+ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ 5ghz-2 {
|
|
+ label = "bcm53xx:white:5ghz-2";
|
|
+ gpios = <&chipcommon 12 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ 2ghz {
|
|
+ label = "bcm53xx:white:2ghz";
|
|
+ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ usb2 {
|
|
+ label = "bcm53xx:white:usb2";
|
|
+ gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ usb3 {
|
|
+ label = "bcm53xx:white:usb3";
|
|
+ gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ brightness {
|
|
+ label = "Backlight";
|
|
+ linux,code = <KEY_BRIGHTNESS_ZERO>;
|
|
+ gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ wps {
|
|
+ label = "WPS";
|
|
+ linux,code = <KEY_WPS_BUTTON>;
|
|
+ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ rfkill {
|
|
+ label = "WiFi";
|
|
+ linux,code = <KEY_RFKILL>;
|
|
+ gpios = <&chipcommon 20 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ status = "okay";
|
|
+ clock-frequency = <125000000>;
|
|
+};
|