76d079204d
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
246 lines
6.6 KiB
Diff
246 lines
6.6 KiB
Diff
From 29b4146ec174f0f598d6b454caa335e8f57e392b Mon Sep 17 00:00:00 2001
|
|
From: Hans de Goede <hdegoede@redhat.com>
|
|
Date: Mon, 28 Jul 2014 23:05:14 +0200
|
|
Subject: [PATCH] ARM: dts: sun7i: Add Banana Pi board
|
|
|
|
The Banana Pi is an A20 based development board using Raspberry Pi compatible
|
|
IO headers. It comes with 1 GB RAM, 1 Gb ethernet, 2x USB host, sata, hdmi
|
|
and stereo audio out + various expenansion headers:
|
|
|
|
http://www.lemaker.org/
|
|
|
|
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/sun7i-a20-bananapi.dts | 214 +++++++++++++++++++++++++++++++
|
|
2 files changed, 215 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/sun7i-a20-bananapi.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -435,6 +435,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
|
|
sun6i-a31-hummingbird.dtb \
|
|
sun6i-a31-m9.dtb
|
|
dtb-$(CONFIG_MACH_SUN7I) += \
|
|
+ sun7i-a20-bananapi.dtb \
|
|
sun7i-a20-cubieboard2.dtb \
|
|
sun7i-a20-cubietruck.dtb \
|
|
sun7i-a20-hummingbird.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/sun7i-a20-bananapi.dts
|
|
@@ -0,0 +1,214 @@
|
|
+/*
|
|
+ * Copyright 2014 Hans de Goede <hdegoede@redhat.com>
|
|
+ *
|
|
+ * Hans de Goede <hdegoede@redhat.com>
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This library is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This library is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public
|
|
+ * License along with this library; if not, write to the Free
|
|
+ * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
|
|
+ * MA 02110-1301 USA
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/include/ "sun7i-a20.dtsi"
|
|
+/include/ "sunxi-common-regulators.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "LeMaker Banana Pi";
|
|
+ compatible = "lemaker,bananapi", "allwinner,sun7i-a20";
|
|
+
|
|
+ soc@01c00000 {
|
|
+ spi0: spi@01c05000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&spi0_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ mmc0: mmc@01c0f000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc0_pins_a>, <&mmc0_cd_pin_bananapi>;
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&pio 7 10 0>; /* PH10 */
|
|
+ cd-inverted;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ usbphy: phy@01c13400 {
|
|
+ usb1_vbus-supply = <®_usb1_vbus>;
|
|
+ usb2_vbus-supply = <®_usb2_vbus>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ehci0: usb@01c14000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ohci0: usb@01c14400 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ahci: sata@01c18000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ehci1: usb@01c1c000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ohci1: usb@01c1c400 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ pinctrl@01c20800 {
|
|
+ mmc0_cd_pin_bananapi: mmc0_cd_pin@0 {
|
|
+ allwinner,pins = "PH10";
|
|
+ allwinner,function = "gpio_in";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <1>;
|
|
+ };
|
|
+
|
|
+ gmac_power_pin_bananapi: gmac_power_pin@0 {
|
|
+ allwinner,pins = "PH23";
|
|
+ allwinner,function = "gpio_out";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <0>;
|
|
+ };
|
|
+
|
|
+ led_pins_bananapi: led_pins@0 {
|
|
+ allwinner,pins = "PH24";
|
|
+ allwinner,function = "gpio_out";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <0>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ ir0: ir@01c21800 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&ir0_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ uart0: serial@01c28000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ uart3: serial@01c28c00 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart3_pins_b>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ uart7: serial@01c29c00 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart7_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ i2c0: i2c@01c2ac00 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c0_pins_a>;
|
|
+ status = "okay";
|
|
+
|
|
+ axp209: pmic@34 {
|
|
+ compatible = "x-powers,axp209";
|
|
+ reg = <0x34>;
|
|
+ interrupt-parent = <&nmi_intc>;
|
|
+ interrupts = <0 8>;
|
|
+
|
|
+ interrupt-controller;
|
|
+ #interrupt-cells = <1>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ i2c2: i2c@01c2b400 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c2_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ gmac: ethernet@01c50000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&gmac_pins_rgmii_a>;
|
|
+ phy = <&phy1>;
|
|
+ phy-mode = "rgmii";
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ status = "okay";
|
|
+
|
|
+ phy1: ethernet-phy@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&led_pins_bananapi>;
|
|
+
|
|
+ green {
|
|
+ label = "bananapi:green:usr";
|
|
+ gpios = <&pio 7 24 0>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_usb1_vbus: usb1-vbus {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ reg_usb2_vbus: usb2-vbus {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&gmac_power_pin_bananapi>;
|
|
+ regulator-name = "gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <50000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 7 23 0>;
|
|
+ };
|
|
+};
|