72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
27 lines
1.0 KiB
Diff
27 lines
1.0 KiB
Diff
Index: linux-3.18-rc4/drivers/pci/host/Kconfig
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/pci/host/Kconfig
|
|
+++ linux-3.18-rc4/drivers/pci/host/Kconfig
|
|
@@ -91,4 +91,9 @@ config PCI_XGENE
|
|
There are 5 internal PCIe ports available. Each port is GEN3 capable
|
|
and have varied lanes from x1 to x8.
|
|
|
|
+config PCI_OXNAS
|
|
+ bool "PLX Oxnas PCIe controller"
|
|
+ depends on ARCH_OXNAS
|
|
+ select PCIEPORTBUS
|
|
+
|
|
endmenu
|
|
Index: linux-3.18-rc4/drivers/pci/host/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/pci/host/Makefile
|
|
+++ linux-3.18-rc4/drivers/pci/host/Makefile
|
|
@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
|
|
obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
|
|
obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
|
|
obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
|
|
+obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
|
|
obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
|
|
obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
|
|
obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o
|