a0d6cd4f49
Add a new kernel config option for generic firmware partition split support and change the uImage split support to depend on the new option. Aslo rename the MTD_UIMAGE_SPLIT_NAME option to MTD_SPLIT_FIRMWARE_NAME to make it more generic. The patch is in preparation for multiple firmware format support. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38002
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -181,6 +181,22 @@ config MTD_BCM47XX_PARTS
|
|
This provides partitions parser for devices based on BCM47xx
|
|
boards.
|
|
|
|
+config MTD_MYLOADER_PARTS
|
|
+ tristate "MyLoader partition parsing"
|
|
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
|
|
+ ---help---
|
|
+ MyLoader is a bootloader which allows the user to define partitions
|
|
+ in flash devices, by putting a table in the second erase block
|
|
+ on the device, similar to a partition table. This table gives the
|
|
+ offsets and lengths of the user defined partitions.
|
|
+
|
|
+ If you need code which can detect and parse these tables, and
|
|
+ register MTD 'partitions' corresponding to each image detected,
|
|
+ enable this option.
|
|
+
|
|
+ You will still need the parsing functions to be called by the driver
|
|
+ for your particular device. It won't happen automatically.
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_BLKDEVS
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
|
|
+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o
|