c2f510f2bd
SVN-Revision: 42698
39 lines
1.2 KiB
Diff
39 lines
1.2 KiB
Diff
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -3,7 +3,6 @@ PROGRAMS += nft
|
|
nft-destdir := @sbindir@
|
|
|
|
nft-obj += main.o
|
|
-nft-obj += cli.o
|
|
nft-obj += rule.o
|
|
nft-obj += statement.o
|
|
nft-obj += datatype.o
|
|
--- a/src/main.c
|
|
+++ b/src/main.c
|
|
@@ -335,7 +335,7 @@ int main(int argc, char * const *argv)
|
|
if (scanner_read_file(scanner, filename, &internal_location) < 0)
|
|
goto out;
|
|
} else if (interactive) {
|
|
- cli_init(&state);
|
|
+ fprintf(stderr, "%s: interactive mode not supported\n", argv[0]);
|
|
return 0;
|
|
} else {
|
|
fprintf(stderr, "%s: no command specified\n", argv[0]);
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -71,13 +71,11 @@ AC_CHECK_LIB([nftnl], [nft_rule_alloc],
|
|
AC_CHECK_LIB([gmp], [__gmpz_init], ,
|
|
AC_MSG_ERROR([No suitable version of libgmp found]))
|
|
|
|
-AC_CHECK_LIB([readline], [readline], ,
|
|
- AC_MSG_ERROR([No suitable version of libreadline found]))
|
|
|
|
# Checks for header files.
|
|
AC_HEADER_STDC
|
|
AC_HEADER_ASSERT
|
|
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h libintl.h limits.h malloc.h \
|
|
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h malloc.h \
|
|
netdb.h netinet/in.h netinet/ip.h netinet/ip6.h \
|
|
netinet/tcp.h netinet/udp.h netinet/ip_icmp.h \
|
|
stddef.h stdint.h stdlib.h string.h unistd.h], ,
|