671361c7ea
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> SVN-Revision: 31474
24 lines
734 B
Diff
24 lines
734 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -31,6 +31,10 @@ config MTD_ROOTFS_SPLIT
|
|
bool "Automatically split 'rootfs' partition for squashfs"
|
|
default y
|
|
|
|
+config MTD_TRXSPLIT
|
|
+ bool "Automatically find and split TRX partitions"
|
|
+ default n
|
|
+
|
|
config MTD_REDBOOT_PARTS
|
|
tristate "RedBoot partition table parsing"
|
|
---help---
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|