cd96421b19
- kexec-tools is now distributed with tarballs of .tar.gz and .tar.xz format; .tar.bz2 are not provided anymore. - Add CONFIG_KEXEC_LZMA for selecting lzma support. Patches are updated along to: - Remove the now unnecessary patch 0004-mips_regdefs.patch. - Drop 100-reduce_size.patch because the size reduction is marginal. - Allow zlib and lzma support coexist together. This patch has been merged into upstream project. - Fix kexec-tools' configure.ac. - Fix a few compilation warnings. Size comparison of stripped binaries of kexec malta target with both zlib and lzma support enabled. - Before: 41447 - After: 42583 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 44437
31 lines
1003 B
Diff
31 lines
1003 B
Diff
From 904e9ae892b0592c916a013869e3be3d830e0155 Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Mon, 9 Feb 2015 20:11:04 +0800
|
|
Subject: [PATCH 4/5] mips: remove unused variable.
|
|
|
|
Fixes the following compilation warning.
|
|
|
|
kexec/arch/mips/crashdump-mips.c:151:6: warning: unused variable 'i' [-Wunused-variable]
|
|
|
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|
---
|
|
kexec/arch/mips/crashdump-mips.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/kexec/arch/mips/crashdump-mips.c b/kexec/arch/mips/crashdump-mips.c
|
|
index 98c9f7c..dc68cb4 100644
|
|
--- a/kexec/arch/mips/crashdump-mips.c
|
|
+++ b/kexec/arch/mips/crashdump-mips.c
|
|
@@ -148,7 +148,7 @@ static int exclude_crash_reserve_region(int *nr_ranges)
|
|
static int get_crash_memory_ranges(struct memory_range **range, int *ranges)
|
|
{
|
|
const char iomem[] = "/proc/iomem";
|
|
- int i, memory_ranges = 0;
|
|
+ int memory_ranges = 0;
|
|
char line[MAX_LINE];
|
|
FILE *fp;
|
|
unsigned long long start, end;
|
|
--
|
|
1.7.10.4
|
|
|