c957af0a0f
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 39471
56 lines
1.9 KiB
Diff
56 lines
1.9 KiB
Diff
From 447675f817b95881e9922f002de3fc7f6d6e9207 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?David=20Lanzend=C3=B6rfer?= <david.lanzendoerfer@o2s.ch>
|
|
Date: Fri, 6 Sep 2013 22:34:33 +0200
|
|
Subject: [PATCH] ARM: sunxi-mci: Add driver for SD/MMC hosts found within
|
|
Allwinner A1X SoCs
|
|
|
|
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
|
---
|
|
drivers/mmc/host/Kconfig | 8 +
|
|
drivers/mmc/host/Makefile | 2 +
|
|
drivers/mmc/host/sunxi-mci.c | 1056 ++++++++++++++++++++++++++++++++++++++++++
|
|
drivers/mmc/host/sunxi-mci.h | 334 +++++++++++++
|
|
4 files changed, 1400 insertions(+)
|
|
create mode 100644 drivers/mmc/host/sunxi-mci.c
|
|
create mode 100644 drivers/mmc/host/sunxi-mci.h
|
|
|
|
diff --git a/drivers/mmc/host/Kconfig b/drivers/mmc/host/Kconfig
|
|
index 7fc5099..0df0322 100644
|
|
--- a/drivers/mmc/host/Kconfig
|
|
+++ b/drivers/mmc/host/Kconfig
|
|
@@ -665,3 +665,11 @@ config MMC_REALTEK_PCI
|
|
help
|
|
Say Y here to include driver code to support SD/MMC card interface
|
|
of Realtek PCI-E card reader
|
|
+
|
|
+config MMC_SUNXI
|
|
+ tristate "Allwinner A1X SD/MMC Host Controller support"
|
|
+ depends on ARCH_SUNXI
|
|
+ default y
|
|
+ help
|
|
+ This selects support for the SD/MMC Host Controller on
|
|
+ Allwinner A1X based SoCs.
|
|
diff --git a/drivers/mmc/host/Makefile b/drivers/mmc/host/Makefile
|
|
index c41d0c3..f76f783 100644
|
|
--- a/drivers/mmc/host/Makefile
|
|
+++ b/drivers/mmc/host/Makefile
|
|
@@ -52,6 +52,8 @@ obj-$(CONFIG_MMC_WMT) += wmt-sdmmc.o
|
|
|
|
obj-$(CONFIG_MMC_REALTEK_PCI) += rtsx_pci_sdmmc.o
|
|
|
|
+obj-$(CONFIG_MMC_SUNXI) += sunxi-mci.o
|
|
+
|
|
obj-$(CONFIG_MMC_SDHCI_PLTFM) += sdhci-pltfm.o
|
|
obj-$(CONFIG_MMC_SDHCI_CNS3XXX) += sdhci-cns3xxx.o
|
|
obj-$(CONFIG_MMC_SDHCI_ESDHC_IMX) += sdhci-esdhc-imx.o
|
|
diff --git a/drivers/mmc/host/sunxi-mci.c b/drivers/mmc/host/sunxi-mci.c
|
|
new file mode 100644
|
|
index 0000000..cbde1d3
|
|
diff --git a/drivers/mmc/host/sunxi-mci.h b/drivers/mmc/host/sunxi-mci.h
|
|
new file mode 100644
|
|
index 0000000..0f5f95c
|
|
\ No newline at end of file
|
|
--
|
|
1.8.5.1
|
|
|