d5dcb1bf97
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
160 lines
3.6 KiB
Diff
160 lines
3.6 KiB
Diff
From ef3bc318adeb15b38688df6a583bafea2befce43 Mon Sep 17 00:00:00 2001
|
|
From: Dan Haab <dhaab@luxul.com>
|
|
Date: Tue, 27 Sep 2016 11:27:11 -0600
|
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Luxul XWR-3100
|
|
|
|
Luxul XWR-3100 is a wireless router based on BCM47094 SoC with two
|
|
4366c0 FullMAC PCIe cards on the PCB. It uses NAND with BCH-4 ECC
|
|
algorithm.
|
|
|
|
Signed-off-by: Dan Haab <dhaab@luxul.com>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts | 111 ++++++++++++++++++++++++++
|
|
arch/arm/boot/dts/bcm5301x-nand-cs0-bch4.dtsi | 13 +++
|
|
3 files changed, 125 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts
|
|
create mode 100644 arch/arm/boot/dts/bcm5301x-nand-cs0-bch4.dtsi
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -78,6 +78,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm4709-netgear-r7000.dtb \
|
|
bcm4709-netgear-r8000.dtb \
|
|
bcm47094-dlink-dir-885l.dtb \
|
|
+ bcm47094-luxul-xwr-3100.dtb \
|
|
bcm47094-netgear-r8500.dtb \
|
|
bcm94708.dtb \
|
|
bcm94709.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts
|
|
@@ -0,0 +1,111 @@
|
|
+/*
|
|
+ * Copyright 2016 Luxul Inc.
|
|
+ *
|
|
+ * Licensed under the ISC license.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm47094.dtsi"
|
|
+#include "bcm5301x-nand-cs0-bch4.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "luxul,xwr-3100v1", "brcm,bcm47094", "brcm,bcm4708";
|
|
+ model = "Luxul XWR-3100 V1";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200 earlycon";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x08000000>;
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ power {
|
|
+ label = "bcm53xx:green:power";
|
|
+ gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ lan3 {
|
|
+ label = "bcm53xx:green:lan1";
|
|
+ gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ lan4 {
|
|
+ label = "bcm53xx:green:lan0";
|
|
+ gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ wan {
|
|
+ label = "bcm53xx:green:wan";
|
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ lan1 {
|
|
+ label = "bcm53xx:green:lan3";
|
|
+ gpios = <&chipcommon 4 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ lan2 {
|
|
+ label = "bcm53xx:green:lan2";
|
|
+ gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ usb3 {
|
|
+ label = "bcm53xx:green:usb3";
|
|
+ gpios = <&chipcommon 8 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ status {
|
|
+ label = "bcm53xx:green:status";
|
|
+ gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "timer";
|
|
+ };
|
|
+
|
|
+ 2ghz {
|
|
+ label = "bcm53xx:green:2ghz";
|
|
+ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ 5ghz {
|
|
+ label = "bcm53xx:green:5ghz";
|
|
+ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb3 {
|
|
+ vcc-gpio = <&chipcommon 18 GPIO_ACTIVE_HIGH>;
|
|
+};
|
|
+
|
|
+&spi_nor {
|
|
+ status = "okay";
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm5301x-nand-cs0-bch4.dtsi
|
|
@@ -0,0 +1,13 @@
|
|
+/*
|
|
+ * Copyright 2016 Luxul Inc.
|
|
+ *
|
|
+ * Licensed under the ISC license.
|
|
+ */
|
|
+
|
|
+#include "bcm5301x-nand-cs0.dtsi"
|
|
+
|
|
+&nandcs {
|
|
+ nand-ecc-algo = "bch";
|
|
+ nand-ecc-strength = <4>;
|
|
+ nand-ecc-step-size = <512>;
|
|
+};
|