81f9cd56a2
We dont't build officialy images for them yet due to partitioning issues. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
73 lines
1.8 KiB
Diff
73 lines
1.8 KiB
Diff
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
|
Subject: [PATCH] ARM: dts: BCM5301X: Add basic DT for Linksys EA9200
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
It's tri-band wireless home router based on BCM4709A0 with 3 x BCM43602
|
|
chipsets. LEDs will be hopefully added later to the DT.
|
|
|
|
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm4709-linksys-ea9200.dts | 42 ++++++++++++++++++++++++++++
|
|
2 files changed, 43 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm4709-linksys-ea9200.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -77,6 +77,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm47081-luxul-xwr-1200.dtb \
|
|
bcm4709-asus-rt-ac87u.dtb \
|
|
bcm4709-buffalo-wxr-1900dhp.dtb \
|
|
+ bcm4709-linksys-ea9200.dtb \
|
|
bcm4709-netgear-r7000.dtb \
|
|
bcm4709-netgear-r8000.dtb \
|
|
bcm4709-tplink-archer-c9-v1.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm4709-linksys-ea9200.dts
|
|
@@ -0,0 +1,42 @@
|
|
+/*
|
|
+ * Copyright (C) 2017 Rafał Miłecki <rafal@milecki.pl>
|
|
+ *
|
|
+ * Licensed under the ISC license.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm4709.dtsi"
|
|
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "linksys,ea9200", "brcm,bcm4709", "brcm,bcm4708";
|
|
+ model = "Linksys EA9200";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x08000000
|
|
+ 0x88000000 0x08000000>;
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ wps {
|
|
+ label = "WPS";
|
|
+ linux,code = <KEY_WPS_BUTTON>;
|
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|