654bc380ec
keep default as 3.14, mt7621 gic need to be ported to 3.18 Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44349
75 lines
1.9 KiB
Diff
75 lines
1.9 KiB
Diff
From af03898c74172ab16d610f3eeaa65f66401eb7db Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <blogic@openwrt.org>
|
|
Date: Tue, 21 May 2013 15:50:31 +0200
|
|
Subject: [PATCH 04/57] MIPS: ralink: adds a bootrom dumper module
|
|
|
|
This patch adds a trivial driver that allows userland to extract the bootrom of
|
|
a SoC via debugfs.
|
|
|
|
Signed-off-by: John Crispin <blogic@openwrt.org>
|
|
---
|
|
arch/mips/ralink/Makefile | 2 ++
|
|
arch/mips/ralink/bootrom.c | 48 ++++++++++++++++++++++++++++++++++++++++++++
|
|
2 files changed, 50 insertions(+)
|
|
create mode 100644 arch/mips/ralink/bootrom.c
|
|
|
|
--- a/arch/mips/ralink/Makefile
|
|
+++ b/arch/mips/ralink/Makefile
|
|
@@ -16,3 +16,5 @@ obj-$(CONFIG_SOC_RT3883) += rt3883.o
|
|
obj-$(CONFIG_SOC_MT7620) += mt7620.o
|
|
|
|
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
|
+
|
|
+obj-$(CONFIG_DEBUG_FS) += bootrom.o
|
|
--- /dev/null
|
|
+++ b/arch/mips/ralink/bootrom.c
|
|
@@ -0,0 +1,48 @@
|
|
+/*
|
|
+ * This program is free software; you can redistribute it and/or modify it
|
|
+ * under the terms of the GNU General Public License version 2 as published
|
|
+ * by the Free Software Foundation.
|
|
+ *
|
|
+ * Copyright (C) 2013 John Crispin <blogic@openwrt.org>
|
|
+ */
|
|
+
|
|
+#include <linux/debugfs.h>
|
|
+#include <linux/seq_file.h>
|
|
+
|
|
+#define BOOTROM_OFFSET 0x10118000
|
|
+#define BOOTROM_SIZE 0x8000
|
|
+
|
|
+static void __iomem *membase = (void __iomem*) KSEG1ADDR(BOOTROM_OFFSET);
|
|
+
|
|
+static int bootrom_show(struct seq_file *s, void *unused)
|
|
+{
|
|
+ seq_write(s, membase, BOOTROM_SIZE);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int bootrom_open(struct inode *inode, struct file *file)
|
|
+{
|
|
+ return single_open(file, bootrom_show, NULL);
|
|
+}
|
|
+
|
|
+static const struct file_operations bootrom_file_ops = {
|
|
+ .open = bootrom_open,
|
|
+ .read = seq_read,
|
|
+ .llseek = seq_lseek,
|
|
+ .release = single_release,
|
|
+};
|
|
+
|
|
+static int bootrom_setup(void)
|
|
+{
|
|
+ if (!debugfs_create_file("bootrom", 0444,
|
|
+ NULL, NULL, &bootrom_file_ops)) {
|
|
+ pr_err("Failed to create bootrom debugfs file\n");
|
|
+
|
|
+ return -EINVAL;
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+postcore_initcall(bootrom_setup);
|