3fc661a98c
As usual these patches were extracted from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Also alphabetically order sound-soc kernel packages. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
286 lines
8.4 KiB
Diff
286 lines
8.4 KiB
Diff
From 347d4cf757e6f093860048fe69737c29f5adcd0f Mon Sep 17 00:00:00 2001
|
|
From: Andrey Grodzovsky <andrey2805@gmail.com>
|
|
Date: Tue, 3 May 2016 22:10:59 -0400
|
|
Subject: [PATCH 326/381] ARM: adau1977-adc: Add basic machine driver for
|
|
adau1977 codec driver.
|
|
|
|
This commit adds basic support for the codec usage including: Device tree overlay,
|
|
binding I2S bus and setting I2S mode, clock source and frequency setting according
|
|
to spec.
|
|
|
|
Signed-off-by: Andrey Grodzovsky <andrey2805@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 7 ++
|
|
.../arm/boot/dts/overlays/adau1977-adc-overlay.dts | 53 +++++++++
|
|
arch/arm/configs/bcm2709_defconfig | 1 +
|
|
arch/arm/configs/bcmrpi_defconfig | 1 +
|
|
sound/soc/bcm/Kconfig | 7 ++
|
|
sound/soc/bcm/Makefile | 2 +
|
|
sound/soc/bcm/adau1977-adc.c | 125 +++++++++++++++++++++
|
|
8 files changed, 197 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/adau1977-adc-overlay.dts
|
|
create mode 100644 sound/soc/bcm/adau1977-adc.c
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -12,6 +12,7 @@ ifeq ($(CONFIG_ARCH_BCM2835),y)
|
|
RPI_DT_OVERLAYS=y
|
|
endif
|
|
|
|
+dtbo-$(RPI_DT_OVERLAYS) += adau1977-adc.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += ads7846.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += akkordion-iqdacplus.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += at86rf233.dtbo
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -161,6 +161,13 @@ Params:
|
|
and the other i2c baudrate parameters.
|
|
|
|
|
|
+Name: adau1977-adc
|
|
+Info: Overlay for activation of ADAU1977 ADC codec over I2C for control
|
|
+ and I2S for data.
|
|
+Load: dtoverlay=adau1977-adc
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: ads7846
|
|
Info: ADS7846 Touch controller
|
|
Load: dtoverlay=ads7846,<param>=<val>
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/adau1977-adc-overlay.dts
|
|
@@ -0,0 +1,53 @@
|
|
+// Definitions for ADAU1977 ADC
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&soc>;
|
|
+
|
|
+ __overlay__ {
|
|
+ codec_supply: fixedregulator@0 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "AVDD";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&i2c>;
|
|
+
|
|
+ __overlay__ {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ adau1977: codec@11 {
|
|
+ compatible = "adi,adau1977";
|
|
+ reg = <0x11>;
|
|
+ reset-gpios = <&gpio 5 0>;
|
|
+ AVDD-supply = <&codec_supply>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&i2s>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@3 {
|
|
+ target = <&sound>;
|
|
+ __overlay__ {
|
|
+ compatible = "adi,adau1977-adc";
|
|
+ i2s-controller = <&i2s>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+};
|
|
--- a/arch/arm/configs/bcm2709_defconfig
|
|
+++ b/arch/arm/configs/bcm2709_defconfig
|
|
@@ -861,6 +861,7 @@ CONFIG_SND_BCM2708_SOC_BOOMBERRY_DAC=m
|
|
CONFIG_SND_BCM2708_SOC_BOOMBERRY_DIGI=m
|
|
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
|
|
CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
|
|
+CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
--- a/arch/arm/configs/bcmrpi_defconfig
|
|
+++ b/arch/arm/configs/bcmrpi_defconfig
|
|
@@ -853,6 +853,7 @@ CONFIG_SND_BCM2708_SOC_BOOMBERRY_DAC=m
|
|
CONFIG_SND_BCM2708_SOC_BOOMBERRY_DIGI=m
|
|
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
|
|
CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
|
|
+CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -78,3 +78,10 @@ config SND_BCM2708_SOC_RASPIDAC3
|
|
select SND_SOC_TPA6130A2
|
|
help
|
|
Say Y or M if you want to add support for RaspiDAC Rev.3x.
|
|
+
|
|
+config SND_BCM2708_SOC_ADAU1977_ADC
|
|
+ tristate "Support for ADAU1977 ADC"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_ADAU1977_I2C
|
|
+ help
|
|
+ Say Y or M if you want to add support for ADAU1977 ADC.
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -4,6 +4,7 @@ snd-soc-bcm2835-i2s-objs := bcm2835-i2s.
|
|
obj-$(CONFIG_SND_BCM2835_SOC_I2S) += snd-soc-bcm2835-i2s.o
|
|
|
|
# BCM2708 Machine Support
|
|
+snd-soc-adau1977-adc-objs := adau1977-adc.o
|
|
snd-soc-hifiberry-dac-objs := hifiberry_dac.o
|
|
snd-soc-hifiberry-dacplus-objs := hifiberry_dacplus.o
|
|
snd-soc-hifiberry-digi-objs := hifiberry_digi.o
|
|
@@ -15,6 +16,7 @@ snd-soc-rpi-proto-objs := rpi-proto.o
|
|
snd-soc-iqaudio-dac-objs := iqaudio-dac.o
|
|
snd-soc-raspidac3-objs := raspidac3.o
|
|
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_ADAU1977_ADC) += snd-soc-adau1977-adc.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS) += snd-soc-hifiberry-dacplus.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DIGI) += snd-soc-hifiberry-digi.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/adau1977-adc.c
|
|
@@ -0,0 +1,125 @@
|
|
+/*
|
|
+ * ASoC Driver for ADAU1977 ADC
|
|
+ *
|
|
+ * Author: Andrey Grodzovsky <andrey2805@gmail.com>
|
|
+ * Copyright 2016
|
|
+ *
|
|
+ * This file is based on hifibery_dac driver by Florian Meier.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+enum adau1977_clk_id {
|
|
+ ADAU1977_SYSCLK,
|
|
+};
|
|
+
|
|
+enum adau1977_sysclk_src {
|
|
+ ADAU1977_SYSCLK_SRC_MCLK,
|
|
+ ADAU1977_SYSCLK_SRC_LRCLK,
|
|
+};
|
|
+
|
|
+static int eval_adau1977_init(struct snd_soc_pcm_runtime *rtd)
|
|
+{
|
|
+ int ret;
|
|
+ struct snd_soc_dai *codec_dai = rtd->codec_dai;
|
|
+
|
|
+ ret = snd_soc_dai_set_tdm_slot(codec_dai, 0, 0, 0, 0);
|
|
+ if (ret < 0)
|
|
+ return ret;
|
|
+
|
|
+ return snd_soc_codec_set_sysclk(rtd->codec, ADAU1977_SYSCLK,
|
|
+ ADAU1977_SYSCLK_SRC_MCLK, 11289600, SND_SOC_CLOCK_IN);
|
|
+}
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_adau1977_dai[] = {
|
|
+ {
|
|
+ .name = "adau1977",
|
|
+ .stream_name = "ADAU1977",
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "adau1977-hifi",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "adau1977.1-0011",
|
|
+ .init = eval_adau1977_init,
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S |
|
|
+ SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBM_CFM,
|
|
+ },
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_adau1977_adc = {
|
|
+ .name = "snd_rpi_adau1977_adc",
|
|
+ .owner = THIS_MODULE,
|
|
+ .dai_link = snd_rpi_adau1977_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_adau1977_dai),
|
|
+};
|
|
+
|
|
+static int snd_adau1977_adc_probe(struct platform_device *pdev)
|
|
+{
|
|
+ int ret = 0;
|
|
+
|
|
+ snd_adau1977_adc.dev = &pdev->dev;
|
|
+ if (pdev->dev.of_node) {
|
|
+ struct device_node *i2s_node;
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_adau1977_dai[0];
|
|
+ i2s_node = of_parse_phandle(pdev->dev.of_node,
|
|
+ "i2s-controller", 0);
|
|
+
|
|
+ if (i2s_node) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_node;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_node;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(&snd_adau1977_adc);
|
|
+ if (ret)
|
|
+ dev_err(&pdev->dev, "snd_soc_register_card() failed: %d\n", ret);
|
|
+
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+static int snd_adau1977_adc_remove(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_unregister_card(&snd_adau1977_adc);
|
|
+}
|
|
+
|
|
+static const struct of_device_id snd_adau1977_adc_of_match[] = {
|
|
+ { .compatible = "adi,adau1977-adc", },
|
|
+ {},
|
|
+};
|
|
+
|
|
+MODULE_DEVICE_TABLE(of, snd_adau1977_adc_of_match);
|
|
+
|
|
+static struct platform_driver snd_adau1977_adc_driver = {
|
|
+ .driver = {
|
|
+ .name = "snd-adau1977-adc",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = snd_adau1977_adc_of_match,
|
|
+ },
|
|
+ .probe = snd_adau1977_adc_probe,
|
|
+ .remove = snd_adau1977_adc_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_adau1977_adc_driver);
|
|
+
|
|
+MODULE_AUTHOR("Andrey Grodzovsky <andrey2805@gmail.com>");
|
|
+MODULE_DESCRIPTION("ASoC Driver for ADAU1977 ADC");
|
|
+MODULE_LICENSE("GPL v2");
|