76d079204d
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
23 lines
788 B
Diff
23 lines
788 B
Diff
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -12,7 +12,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
--- a/arch/mips/ar7/platform.c
|
|
+++ b/arch/mips/ar7/platform.c
|
|
@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
|
|
.name = "mem",
|
|
.flags = IORESOURCE_MEM,
|
|
.start = 0x10000000,
|
|
- .end = 0x107fffff,
|
|
+ .end = 0x11ffffff,
|
|
};
|
|
|
|
static const char *ar7_probe_types[] = { "ar7part", NULL };
|