a0c49ef46f
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
32 lines
1.0 KiB
Diff
32 lines
1.0 KiB
Diff
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
|
|
This allows LEDs to be controlled by network device activity.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_USBDEV
|
|
+ tristate "LED USB device Trigger"
|
|
+ depends on USB && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by the presence/activity of
|
|
+ an USB device. If unsure, say N.
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -67,3 +67,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
|
|
--- a/drivers/leds/ledtrig-usbdev.c
|
|
+++ b/drivers/leds/ledtrig-usbdev.c
|
|
@@ -24,7 +24,6 @@
|
|
#include <linux/list.h>
|
|
#include <linux/spinlock.h>
|
|
#include <linux/device.h>
|
|
-#include <linux/sysdev.h>
|
|
#include <linux/timer.h>
|
|
#include <linux/ctype.h>
|
|
#include <linux/slab.h>
|