a0c49ef46f
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
89 lines
2.7 KiB
Diff
89 lines
2.7 KiB
Diff
--- a/include/asm-generic/vmlinux.lds.h
|
|
+++ b/include/asm-generic/vmlinux.lds.h
|
|
@@ -54,6 +54,16 @@
|
|
#define LOAD_OFFSET 0
|
|
#endif
|
|
|
|
+#ifndef SYMTAB_KEEP
|
|
+#define SYMTAB_KEEP KEEP(*(SORT(___ksymtab+*)))
|
|
+#define SYMTAB_KEEP_GPL KEEP(*(SORT(___ksymtab_gpl+*)))
|
|
+#endif
|
|
+
|
|
+#ifndef SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD_GPL
|
|
+#endif
|
|
+
|
|
#include <linux/export.h>
|
|
|
|
/* Align . to a 8 byte boundary equals to maximum function alignment. */
|
|
@@ -301,14 +311,14 @@
|
|
/* Kernel symbol table: Normal symbols */ \
|
|
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \
|
|
VMLINUX_SYMBOL(__start___ksymtab) = .; \
|
|
- KEEP(*(SORT(___ksymtab+*))) \
|
|
+ SYMTAB_KEEP \
|
|
VMLINUX_SYMBOL(__stop___ksymtab) = .; \
|
|
} \
|
|
\
|
|
/* Kernel symbol table: GPL-only symbols */ \
|
|
__ksymtab_gpl : AT(ADDR(__ksymtab_gpl) - LOAD_OFFSET) { \
|
|
VMLINUX_SYMBOL(__start___ksymtab_gpl) = .; \
|
|
- KEEP(*(SORT(___ksymtab_gpl+*))) \
|
|
+ SYMTAB_KEEP_GPL \
|
|
VMLINUX_SYMBOL(__stop___ksymtab_gpl) = .; \
|
|
} \
|
|
\
|
|
@@ -370,7 +380,7 @@
|
|
\
|
|
/* Kernel symbol table: strings */ \
|
|
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \
|
|
- *(__ksymtab_strings) \
|
|
+ *(__ksymtab_strings+*) \
|
|
} \
|
|
\
|
|
/* __*init sections */ \
|
|
@@ -696,6 +706,8 @@
|
|
EXIT_TEXT \
|
|
EXIT_DATA \
|
|
EXIT_CALL \
|
|
+ SYMTAB_DISCARD \
|
|
+ SYMTAB_DISCARD_GPL \
|
|
*(.discard) \
|
|
*(.discard.*) \
|
|
}
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -299,7 +299,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
|
|
# Linker scripts preprocessor (.lds.S -> .lds)
|
|
# ---------------------------------------------------------------------------
|
|
quiet_cmd_cpp_lds_S = LDS $@
|
|
- cmd_cpp_lds_S = $(CPP) $(cpp_flags) -P -C -U$(ARCH) \
|
|
+ cmd_cpp_lds_S = $(CPP) $(EXTRA_LDSFLAGS) $(cpp_flags) -P -C -U$(ARCH) \
|
|
-D__ASSEMBLY__ -DLINKER_SCRIPT -o $@ $<
|
|
|
|
$(obj)/%.lds: $(src)/%.lds.S FORCE
|
|
--- a/include/linux/export.h
|
|
+++ b/include/linux/export.h
|
|
@@ -52,12 +52,19 @@ extern struct module __this_module;
|
|
#define __CRC_SYMBOL(sym, sec)
|
|
#endif
|
|
|
|
+#ifdef MODULE
|
|
+#define __EXPORT_SUFFIX(sym)
|
|
+#else
|
|
+#define __EXPORT_SUFFIX(sym) "+" #sym
|
|
+#endif
|
|
+
|
|
/* For every exported symbol, place a struct in the __ksymtab section */
|
|
#define __EXPORT_SYMBOL(sym, sec) \
|
|
extern typeof(sym) sym; \
|
|
__CRC_SYMBOL(sym, sec) \
|
|
static const char __kstrtab_##sym[] \
|
|
- __attribute__((section("__ksymtab_strings"), aligned(1))) \
|
|
+ __attribute__((section("__ksymtab_strings" \
|
|
+ __EXPORT_SUFFIX(sym)), aligned(1))) \
|
|
= VMLINUX_SYMBOL_STR(sym); \
|
|
extern const struct kernel_symbol __ksymtab_##sym; \
|
|
__visible const struct kernel_symbol __ksymtab_##sym \
|