72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
41 lines
1.7 KiB
Diff
41 lines
1.7 KiB
Diff
Index: linux-3.18-rc4/drivers/irqchip/Kconfig
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/irqchip/Kconfig
|
|
+++ linux-3.18-rc4/drivers/irqchip/Kconfig
|
|
@@ -15,6 +15,11 @@ config ARM_GIC_V3
|
|
select IRQ_DOMAIN
|
|
select MULTI_IRQ_HANDLER
|
|
|
|
+config PLXTECH_RPS
|
|
+ def_bool y if ARHC_OXNAS
|
|
+ depends on ARCH_OXNAS
|
|
+ select IRQ_DOMAIN
|
|
+
|
|
config ARM_NVIC
|
|
bool
|
|
select IRQ_DOMAIN
|
|
Index: linux-3.18-rc4/drivers/irqchip/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/irqchip/Makefile
|
|
+++ linux-3.18-rc4/drivers/irqchip/Makefile
|
|
@@ -28,6 +28,7 @@ obj-$(CONFIG_IMGPDC_IRQ) += irq-imgpdc.
|
|
obj-$(CONFIG_SIRF_IRQ) += irq-sirfsoc.o
|
|
obj-$(CONFIG_RENESAS_INTC_IRQPIN) += irq-renesas-intc-irqpin.o
|
|
obj-$(CONFIG_RENESAS_IRQC) += irq-renesas-irqc.o
|
|
+obj-$(CONFIG_PLXTECH_RPS) += irq-rps.o
|
|
obj-$(CONFIG_VERSATILE_FPGA_IRQ) += irq-versatile-fpga.o
|
|
obj-$(CONFIG_ARCH_NSPIRE) += irq-zevio.o
|
|
obj-$(CONFIG_ARCH_VT8500) += irq-vt8500.o
|
|
Index: linux-3.18-rc4/drivers/irqchip/irq-gic.c
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/irqchip/irq-gic.c
|
|
+++ linux-3.18-rc4/drivers/irqchip/irq-gic.c
|
|
@@ -1044,6 +1044,7 @@ IRQCHIP_DECLARE(gic_400, "arm,gic-400",
|
|
IRQCHIP_DECLARE(cortex_a15_gic, "arm,cortex-a15-gic", gic_of_init);
|
|
IRQCHIP_DECLARE(cortex_a9_gic, "arm,cortex-a9-gic", gic_of_init);
|
|
IRQCHIP_DECLARE(cortex_a7_gic, "arm,cortex-a7-gic", gic_of_init);
|
|
+IRQCHIP_DECLARE(arm11_mpcore_gic, "arm,arm11mp-gic", gic_of_init);
|
|
IRQCHIP_DECLARE(msm_8660_qgic, "qcom,msm-8660-qgic", gic_of_init);
|
|
IRQCHIP_DECLARE(msm_qgic2, "qcom,msm-qgic2", gic_of_init);
|
|
|