72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
25 lines
813 B
Diff
25 lines
813 B
Diff
Index: linux-3.18-rc4/drivers/reset/Kconfig
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/reset/Kconfig
|
|
+++ linux-3.18-rc4/drivers/reset/Kconfig
|
|
@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
|
|
|
|
If unsure, say no.
|
|
|
|
+config RESET_CONTROLLER_OXNAS
|
|
+ bool
|
|
+ select RESET_CONTROLLER
|
|
+
|
|
source "drivers/reset/sti/Kconfig"
|
|
+
|
|
Index: linux-3.18-rc4/drivers/reset/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/reset/Makefile
|
|
+++ linux-3.18-rc4/drivers/reset/Makefile
|
|
@@ -1,4 +1,5 @@
|
|
obj-$(CONFIG_RESET_CONTROLLER) += core.o
|
|
+obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
|
|
obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
|
|
obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o
|
|
obj-$(CONFIG_ARCH_STI) += sti/
|