548d9a008f
Several versions of gcc have an issue in libstdc++v3 where the build may clobber stamp-bits with a link to itself. This doesn't manifest itself on all systems. On several Ubuntu systems, this doesn't appear to be a problem, but it is an issue on Fedora 16 systems. To fix the issue, we'll simply filter out stamp-bits from the symlinks to be generated. Note: gcc 4.4.7 is unaffected by this issue, so no fix is necessary there. Signed-off-by: John Szakmeister <john@szakmeister.net> SVN-Revision: 43669
12 lines
364 B
Diff
12 lines
364 B
Diff
--- a/libstdc++-v3/include/Makefile.in
|
|
+++ b/libstdc++-v3/include/Makefile.in
|
|
@@ -1342,7 +1342,7 @@
|
|
@$(STAMP) stamp-bits
|
|
|
|
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
|
- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
|
|
+ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
|
|
@$(STAMP) stamp-bits-sup
|
|
|
|
stamp-c_base: ${c_base_headers}
|