3b21b2ae00
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43915
23 lines
784 B
Diff
23 lines
784 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -490,4 +490,12 @@ config LEDS_BLINKM
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
+config LEDS_TRIGGER_ADM5120_SWITCH
|
|
+ tristate "LED ADM5120 Switch Port Status Trigger"
|
|
+ depends on LEDS_TRIGGERS && ADM5120
|
|
+ help
|
|
+ This allows LEDs to be controlled by the port states of
|
|
+ the ADM5120 built-in Ethernet Switch
|
|
+ If unsure, say N.
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -63,3 +63,4 @@ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
|