f4afa00862
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 SVN-Revision: 32462
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
--- a/drivers/char/hw_random/Kconfig
|
|
+++ b/drivers/char/hw_random/Kconfig
|
|
@@ -188,6 +188,18 @@ config HW_RANDOM_TX4939
|
|
|
|
If unsure, say Y.
|
|
|
|
+config HW_RANDOM_MCS814X
|
|
+ tristate "Moschip MCS814x Random Number Generator"
|
|
+ depends on HW_RANDOM && ARCH_MCS814X
|
|
+ ---help---
|
|
+ This driver provides kernel-side support for the Random Number
|
|
+ Generator hardware found on Moschip MCS814x processors.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the
|
|
+ module will be called mcs814x-rng.
|
|
+
|
|
+ If unusure, say Y.
|
|
+
|
|
config HW_RANDOM_MXC_RNGA
|
|
tristate "Freescale i.MX RNGA Random Number Generator"
|
|
depends on HW_RANDOM && ARCH_HAS_RNGA
|
|
--- a/drivers/char/hw_random/Makefile
|
|
+++ b/drivers/char/hw_random/Makefile
|
|
@@ -17,6 +17,7 @@ obj-$(CONFIG_HW_RANDOM_OMAP) += omap-rng
|
|
obj-$(CONFIG_HW_RANDOM_PASEMI) += pasemi-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_VIRTIO) += virtio-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_TX4939) += tx4939-rng.o
|
|
+obj-$(CONFIG_HW_RANDOM_MCS814X) += mcs814x-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_MXC_RNGA) += mxc-rnga.o
|
|
obj-$(CONFIG_HW_RANDOM_OCTEON) += octeon-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_NOMADIK) += nomadik-rng.o
|