f4afa00862
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 SVN-Revision: 32462
26 lines
801 B
Diff
26 lines
801 B
Diff
--- a/drivers/watchdog/Kconfig
|
|
+++ b/drivers/watchdog/Kconfig
|
|
@@ -343,6 +343,12 @@ config IMX2_WDT
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called imx2_wdt.
|
|
|
|
+config MCS814X_WATCHDOG
|
|
+ tristate "Moschip MCS814x watchdog"
|
|
+ depends on WATCHDOG_CORE && ARCH_MCS814X
|
|
+ help
|
|
+ Support for the Moschip MCS814x SoCs on-chip watchdog timer.
|
|
+
|
|
# AVR32 Architecture
|
|
|
|
config AT32AP700X_WDT
|
|
--- a/drivers/watchdog/Makefile
|
|
+++ b/drivers/watchdog/Makefile
|
|
@@ -53,6 +53,7 @@ obj-$(CONFIG_STMP3XXX_WATCHDOG) += stmp3
|
|
obj-$(CONFIG_NUC900_WATCHDOG) += nuc900_wdt.o
|
|
obj-$(CONFIG_TS72XX_WATCHDOG) += ts72xx_wdt.o
|
|
obj-$(CONFIG_IMX2_WDT) += imx2_wdt.o
|
|
+obj-$(CONFIG_MCS814X_WATCHDOG) += mcs814x_wdt.o
|
|
|
|
# AVR32 Architecture
|
|
obj-$(CONFIG_AT32AP700X_WDT) += at32ap700x_wdt.o
|