696c29fa4d
SVN-Revision: 17817
163 lines
6.4 KiB
Diff
163 lines
6.4 KiB
Diff
Index: linux-2.6.30.5/drivers/char/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/char/Makefile 2009-09-02 18:22:49.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/char/Makefile 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -112,6 +112,10 @@
|
|
obj-$(CONFIG_JS_RTC) += js-rtc.o
|
|
js-rtc-y = rtc.o
|
|
|
|
+obj-$(CONFIG_IFXMIPS_SSC) += ifxmips_ssc.o
|
|
+obj-$(CONFIG_IFXMIPS_EEPROM) += ifxmips_eeprom.o
|
|
+obj-$(CONFIG_IFXMIPS_MEI) += ifxmips_mei_core.o
|
|
+
|
|
# Files generated that shall be removed upon make clean
|
|
clean-files := consolemap_deftbl.c defkeymap.c
|
|
|
|
Index: linux-2.6.30.5/drivers/mtd/maps/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/mtd/maps/Makefile 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/mtd/maps/Makefile 2009-09-02 18:30:09.000000000 +0200
|
|
@@ -62,3 +62,4 @@
|
|
obj-$(CONFIG_MTD_BFIN_ASYNC) += bfin-async-flash.o
|
|
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
|
|
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
|
|
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
|
Index: linux-2.6.30.5/drivers/net/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/net/Kconfig 2009-09-02 18:22:49.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/net/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -353,6 +353,12 @@
|
|
|
|
source "drivers/net/arm/Kconfig"
|
|
|
|
+config IFXMIPS_MII0
|
|
+ tristate "Infineon IFXMips eth0 driver"
|
|
+ depends on IFXMIPS
|
|
+ help
|
|
+ Support for the MII0 inside the IFXMips SOC
|
|
+
|
|
config AX88796
|
|
tristate "ASIX AX88796 NE2000 clone support"
|
|
depends on ARM || MIPS || SUPERH
|
|
Index: linux-2.6.30.5/drivers/serial/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/serial/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/serial/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -1365,6 +1365,14 @@
|
|
help
|
|
Support for Console on the NWP serial ports.
|
|
|
|
+config SERIAL_IFXMIPS
|
|
+ bool "IFXMips serial driver"
|
|
+ depends on IFXMIPS
|
|
+ select SERIAL_CORE
|
|
+ select SERIAL_CORE_CONSOLE
|
|
+ help
|
|
+ Driver for the ifxmipss built in ASC hardware
|
|
+
|
|
config SERIAL_QE
|
|
tristate "Freescale QUICC Engine serial port support"
|
|
depends on QUICC_ENGINE
|
|
Index: linux-2.6.30.5/drivers/serial/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/serial/Makefile 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/serial/Makefile 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -77,3 +77,4 @@
|
|
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
|
obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
|
|
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
|
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
|
Index: linux-2.6.30.5/drivers/watchdog/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -105,6 +105,7 @@
|
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
|
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
|
|
|
|
# PARISC Architecture
|
|
|
|
Index: linux-2.6.30.5/drivers/net/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/net/Makefile 2009-09-02 18:22:49.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/net/Makefile 2009-09-02 18:30:37.000000000 +0200
|
|
@@ -234,6 +234,7 @@
|
|
obj-$(CONFIG_MLX4_CORE) += mlx4/
|
|
obj-$(CONFIG_ENC28J60) += enc28j60.o
|
|
obj-$(CONFIG_ETHOC) += ethoc.o
|
|
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
|
|
|
|
obj-$(CONFIG_XTENSA_XT2000_SONIC) += xtsonic.o
|
|
|
|
Index: linux-2.6.30.5/drivers/crypto/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/crypto/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/crypto/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -9,6 +9,9 @@
|
|
If you say N, all options in this submenu will be skipped and disabled.
|
|
|
|
if CRYPTO_HW
|
|
+config CRYPTO_DEV_IFXMIPS
|
|
+ tristate "Support for IFXMIPS Data Encryption Unit"
|
|
+ depends on IFXMIPS
|
|
|
|
config CRYPTO_DEV_PADLOCK
|
|
tristate "Support for VIA PadLock ACE"
|
|
Index: linux-2.6.30.5/drivers/crypto/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/crypto/Makefile 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/crypto/Makefile 2009-09-02 18:30:55.000000000 +0200
|
|
@@ -5,3 +5,4 @@
|
|
obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
|
|
obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
|
|
obj-$(CONFIG_CRYPTO_DEV_PPC4XX) += amcc/
|
|
+obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o
|
|
Index: linux-2.6.30.5/drivers/leds/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/leds/Kconfig 2009-09-02 18:22:49.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/leds/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -227,6 +227,12 @@
|
|
This option enables support for BD2802GU RGB LED driver chips
|
|
accessed via the I2C bus.
|
|
|
|
+config LEDS_IFXMIPS
|
|
+ tristate "LED Support for IFXMIPS LEDs"
|
|
+ depends on LEDS_CLASS && IFXMIPS
|
|
+ help
|
|
+ This option enables support for the CM-X270 LEDs.
|
|
+
|
|
comment "LED Triggers"
|
|
|
|
config LEDS_TRIGGERS
|
|
Index: linux-2.6.30.5/drivers/leds/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/leds/Makefile 2009-09-02 18:22:49.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/leds/Makefile 2009-09-02 18:31:23.000000000 +0200
|
|
@@ -27,6 +27,7 @@
|
|
obj-$(CONFIG_LEDS_DA903X) += leds-da903x.o
|
|
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
|
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
+obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
|
|
|
|
# LED SPI Drivers
|
|
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
|
Index: linux-2.6.30.5/drivers/watchdog/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
|
+++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
|
@@ -764,6 +764,12 @@
|
|
help
|
|
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
|
|
|
+config IFXMIPS_WDT
|
|
+ bool "IFXMips watchdog"
|
|
+ depends on IFXMIPS
|
|
+ help
|
|
+ Hardware driver for the IFXMIPS Watchdog Timer.
|
|
+
|
|
# PARISC Architecture
|
|
|
|
# POWERPC Architecture
|