4e155c80d3
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40393
29 lines
749 B
Diff
29 lines
749 B
Diff
--- a/drivers/net/wireless/ath/Makefile
|
|
+++ b/drivers/net/wireless/ath/Makefile
|
|
@@ -13,8 +13,8 @@ ath-objs := main.o \
|
|
regd.o \
|
|
hw.o \
|
|
key.o \
|
|
+ debug.o \
|
|
dfs_pattern_detector.o \
|
|
dfs_pri_detector.o
|
|
|
|
-ath-$(CPTCFG_ATH_DEBUG) += debug.o
|
|
ccflags-y += -D__CHECK_ENDIAN__
|
|
--- a/drivers/net/wireless/ath/ath.h
|
|
+++ b/drivers/net/wireless/ath/ath.h
|
|
@@ -295,13 +295,6 @@ void _ath_dbg(struct ath_common *common,
|
|
#endif /* CPTCFG_ATH_DEBUG */
|
|
|
|
/** Returns string describing opmode, or NULL if unknown mode. */
|
|
-#ifdef CPTCFG_ATH_DEBUG
|
|
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
|
|
-#else
|
|
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
|
|
-{
|
|
- return "UNKNOWN";
|
|
-}
|
|
-#endif
|
|
|
|
#endif /* ATH_H */
|