0bec90b830
Signed-off-by: Forest Crossman <cyrozap@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/5714/ [juhosg: - drop nvram.c modifications, - create a separate kernel patch, - use ath79_setup_qca955x_eth_cfg helper, - merge esr900_{010,common}_setup functions, - statically init AR8327 pad configurations, - use pr_err instead of printk] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 41640
40 lines
1.5 KiB
Diff
40 lines
1.5 KiB
Diff
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -47,6 +47,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_DIR_825_C1, /* D-Link DIR-825 rev. C1 */
|
|
ATH79_MACH_DIR_835_A1, /* D-Link DIR-835 rev. A1 */
|
|
ATH79_MACH_DRAGINO2, /* Dragino Version 2 */
|
|
+ ATH79_MACH_ESR900, /* EnGenius ESR900 */
|
|
ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
|
|
ATH79_MACH_EW_DORIN_ROUTER, /* embedded wireless Dorin Router Platform */
|
|
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
|
|
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -335,6 +335,16 @@ config ATH79_MACH_DRAGINO2
|
|
select ATH79_DEV_ETH
|
|
select ATH79_DEV_USB
|
|
|
|
+config ATH79_MACH_ESR900
|
|
+ bool "EnGenius ESR900 board support"
|
|
+ select SOC_QCA955X
|
|
+ select ATH79_DEV_ETH
|
|
+ select ATH79_DEV_GPIO_BUTTONS
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_SPI
|
|
+ select ATH79_DEV_USB
|
|
+ select ATH79_DEV_WMAC
|
|
+
|
|
config ATH79_MACH_EW_DORIN
|
|
bool "embedded wireless Dorin Platform support"
|
|
select SOC_AR933X
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -60,6 +60,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += m
|
|
obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
|
|
obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += mach-dir-825-c1.o
|
|
obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
|
|
+obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
|
|
obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
|
|
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
|
|
obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
|