f4afa00862
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 SVN-Revision: 32462
17 lines
599 B
Diff
17 lines
599 B
Diff
--- a/drivers/net/ethernet/Kconfig
|
|
+++ b/drivers/net/ethernet/Kconfig
|
|
@@ -176,4 +176,6 @@ source "drivers/net/ethernet/via/Kconfig
|
|
source "drivers/net/ethernet/xilinx/Kconfig"
|
|
source "drivers/net/ethernet/xircom/Kconfig"
|
|
|
|
+source "drivers/net/ethernet/mcs8140/Kconfig"
|
|
+
|
|
endif # ETHERNET
|
|
--- a/drivers/net/ethernet/Makefile
|
|
+++ b/drivers/net/ethernet/Makefile
|
|
@@ -74,3 +74,4 @@ obj-$(CONFIG_NET_VENDOR_TUNDRA) += tundr
|
|
obj-$(CONFIG_NET_VENDOR_VIA) += via/
|
|
obj-$(CONFIG_NET_VENDOR_XILINX) += xilinx/
|
|
obj-$(CONFIG_NET_VENDOR_XIRCOM) += xircom/
|
|
+obj-$(CONFIG_NUPORT_ETHERNET_DRIVER) += mcs8140/
|