0cd478518f
Fixes a regression on spi flash devices (upstream commit 1583eaece6fa). Changelogs: * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.7 * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.8 * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.9 * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.10 096-ipv4-off-by-one-in-continuation-handling-in-proc-net.patch was applied upstream and dropped. Signed-off-by: Mathias Kresin <openwrt@kresin.me> [update from 4.1.9 to 4.1.10] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47104
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
Upstream doesn't optimize the kernel and bootwrappers for ppc44x because
|
|
they still want to support gcc 3.3 -- well, we don't.
|
|
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -203,7 +203,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
|
KBUILD_CFLAGS += -mno-sched-epilog
|
|
endif
|
|
|
|
-cpu-as-$(CONFIG_4xx) += -Wa,-m405
|
|
+cpu-as-$(CONFIG_40x) += -Wa,-m405
|
|
+cpu-as-$(CONFIG_44x) += -Wa,-m440
|
|
cpu-as-$(CONFIG_ALTIVEC) += -Wa,-maltivec
|
|
cpu-as-$(CONFIG_E200) += -Wa,-me200
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -48,10 +48,10 @@ BOOTCFLAGS += -I$(obj) -I$(srctree)/$(ob
|
|
DTC_FLAGS ?= -p 1024
|
|
|
|
$(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
|
|
+$(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
|
|
$(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
|
|
+$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
|
|
+$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
|
|
$(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
|
|
$(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
|
|
$(obj)/treeboot-iss4xx.o: BOOTCFLAGS += -mcpu=405
|