3b798d819d
SVN-Revision: 35193
23 lines
892 B
Diff
23 lines
892 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -11780,7 +11780,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
|
if test -n "$kbuilddir"; then
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
|
|
$as_echo_n "checking kernel version that we will build against... " >&6; }
|
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
|
kmajor="${krel%%[^0-9]*}";
|
|
kmajor="$(($kmajor+0))";
|
|
krel="${krel:${#kmajor}}";
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
|
|
|
if test -n "$kbuilddir"; then
|
|
AC_MSG_CHECKING([kernel version that we will build against])
|
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
|
kmajor="${krel%%[[^0-9]]*}";
|
|
kmajor="$(($kmajor+0))";
|
|
krel="${krel:${#kmajor}}";
|