bff468813f
- Includes large parts of the patch from #1021 by dpalffy - Includes RB532 NAND driver changes by n0-1 SVN-Revision: 5789
23 lines
925 B
Diff
23 lines
925 B
Diff
diff -urN linux-2.6.19.old/fs/squashfs/Makefile linux-2.6.19.dev/fs/squashfs/Makefile
|
|
--- linux-2.6.19.old/fs/squashfs/Makefile 2006-12-14 03:13:22.000000000 +0100
|
|
+++ linux-2.6.19.dev/fs/squashfs/Makefile 2006-12-14 03:13:31.000000000 +0100
|
|
@@ -4,5 +4,4 @@
|
|
|
|
obj-$(CONFIG_SQUASHFS) += squashfs.o
|
|
squashfs-y += inode.o
|
|
-squashfs-y += squashfs2_0.o
|
|
squashfs-y += LzmaDecode.o
|
|
diff -urN linux-2.6.19.old/fs/squashfs/squashfs.h linux-2.6.19.dev/fs/squashfs/squashfs.h
|
|
--- linux-2.6.19.old/fs/squashfs/squashfs.h 2006-12-14 03:13:20.000000000 +0100
|
|
+++ linux-2.6.19.dev/fs/squashfs/squashfs.h 2006-12-14 03:13:31.000000000 +0100
|
|
@@ -24,6 +24,9 @@
|
|
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
|
|
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
|
|
#endif
|
|
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
|
|
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
|
|
+#endif
|
|
|
|
#ifdef SQUASHFS_TRACE
|
|
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)
|