8996164e56
All supported kernels require patching ledtrig-netdev in the same way, so it's safe to just move these changes to the base version of this driver. We needed these patches for some old kernels 2.6.36 and 3.11. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 47962
22 lines
672 B
Diff
22 lines
672 B
Diff
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -112,4 +112,11 @@ config LEDS_TRIGGER_MORSE
|
|
tristate "LED Morse Trigger"
|
|
depends on LEDS_TRIGGERS
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on NET && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -66,3 +66,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|