76d079204d
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
63 lines
2.2 KiB
Diff
63 lines
2.2 KiB
Diff
From b12e230f09d4481424e6a5d7e2ae566b6954e83f Mon Sep 17 00:00:00 2001
|
|
From: Mathieu Olivari <mathieu@codeaurora.org>
|
|
Date: Wed, 29 Apr 2015 15:21:46 -0700
|
|
Subject: [PATCH] HACK: arch: arm: force ZRELADDR on arch-qcom
|
|
|
|
ARCH_QCOM is using the ARCH_MULTIPLATFORM option, as now recommended
|
|
on most ARM architectures. This automatically calculate ZRELADDR by
|
|
masking PHYS_OFFSET with 0xf8000000.
|
|
|
|
However, on IPQ806x, the first ~20MB of RAM is reserved for the hardware
|
|
network accelerators, and the bootloader removes this section from the
|
|
layout passed from the ATAGS (when used).
|
|
|
|
For newer bootloader, when DT is used, this is not a problem, we just
|
|
reserve this memory in the device tree. But if the bootloader doesn't
|
|
have DT support, then ATAGS have to be used. In this case, the ARM
|
|
decompressor will position the kernel in this low mem, which will not be
|
|
in the RAM section mapped by the bootloader, which means the kernel will
|
|
freeze in the middle of the boot process trying to map the memory.
|
|
|
|
As a work around, this patch allows disabling AUTO_ZRELADDR when
|
|
ARCH_QCOM is selected. It makes the zImage usage possible on bootloaders
|
|
which don't support device-tree, which is the case on certain early
|
|
IPQ806x based designs.
|
|
|
|
Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
|
|
---
|
|
arch/arm/Kconfig | 2 +-
|
|
arch/arm/Makefile | 2 ++
|
|
arch/arm/mach-qcom/Makefile.boot | 1 +
|
|
3 files changed, 4 insertions(+), 1 deletion(-)
|
|
create mode 100644 arch/arm/mach-qcom/Makefile.boot
|
|
|
|
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -311,7 +311,7 @@ config ARCH_MULTIPLATFORM
|
|
select ARCH_WANT_OPTIONAL_GPIOLIB
|
|
select ARM_HAS_SG_CHAIN
|
|
select ARM_PATCH_PHYS_VIRT
|
|
- select AUTO_ZRELADDR
|
|
+ select AUTO_ZRELADDR if !ARCH_QCOM
|
|
select CLKSRC_OF
|
|
select COMMON_CLK
|
|
select GENERIC_CLOCKEVENTS
|
|
--- a/arch/arm/Makefile
|
|
+++ b/arch/arm/Makefile
|
|
@@ -240,9 +240,11 @@ MACHINE := arch/arm/mach-$(word 1,$(mac
|
|
else
|
|
MACHINE :=
|
|
endif
|
|
+ifeq ($(CONFIG_ARCH_QCOM),)
|
|
ifeq ($(CONFIG_ARCH_MULTIPLATFORM),y)
|
|
MACHINE :=
|
|
endif
|
|
+endif
|
|
|
|
machdirs := $(patsubst %,arch/arm/mach-%/,$(machine-y))
|
|
platdirs := $(patsubst %,arch/arm/plat-%/,$(sort $(plat-y)))
|
|
--- /dev/null
|
|
+++ b/arch/arm/mach-qcom/Makefile.boot
|
|
@@ -0,0 +1 @@
|
|
+zreladdr-y+= 0x42208000
|