4153768fd6
SVN-Revision: 20253
22 lines
706 B
Diff
22 lines
706 B
Diff
--- a/drivers/power/Makefile
|
|
+++ b/drivers/power/Makefile
|
|
@@ -30,3 +30,4 @@ obj-$(CONFIG_BATTERY_DA9030) += da9030_b
|
|
obj-$(CONFIG_BATTERY_MAX17040) += max17040_battery.o
|
|
obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
|
|
obj-$(CONFIG_BATTERY_JZ4740) += jz4740-battery.o
|
|
+obj-$(CONFIG_CHARGER_GPIO) += gpio-charger.o
|
|
--- a/drivers/power/Kconfig
|
|
+++ b/drivers/power/Kconfig
|
|
@@ -121,4 +121,11 @@ config BATTERY_JZ4740
|
|
This driver can be build as a module. If so, the module will be
|
|
called jz4740-battery.
|
|
|
|
+config CHARGER_GPIO
|
|
+ tristate "GPIO charger"
|
|
+ depends on GPIOLIB
|
|
+ help
|
|
+ Say Y to include support for chargers indicating their status through
|
|
+ a GPIO pin.
|
|
+
|
|
endif # POWER_SUPPLY
|