a7525f5f5d
[juhosg: - remove custom mdio bus info and platform data for ar8327, clear the .led_cfg field from dir835a1_setup instead, - remove arguments of dir835c1_generic_setup function, register the LEDs directly from the board specific setup instead] Signed-off-by: Alexander Stadler <sa.maillists@univie.ac.at> Patchwork: http://patchwork.openwrt.org/patch/3426/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35957
50 lines
1.8 KiB
Diff
50 lines
1.8 KiB
Diff
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -71,6 +71,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_RB_750G_R3, /* MikroTik RouterBOARD 750GL */
|
|
ATH79_MACH_RB_751, /* MikroTik RouterBOARD 751 */
|
|
ATH79_MACH_RB_751G, /* Mikrotik RouterBOARD 751G */
|
|
+ ATH79_MACH_RB_951G, /* Mikrotik RouterBOARD 951G */
|
|
ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
|
|
ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
|
|
ATH79_MACH_RW2458N, /* Redwave RW2458N */
|
|
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -360,6 +360,16 @@ config ATH79_MACH_RB750
|
|
select ATH79_ROUTERBOOT
|
|
select RLE_DECOMPRESS
|
|
|
|
+config ATH79_MACH_RB95X
|
|
+ bool "MikroTik RouterBOARD 95X support"
|
|
+ select SOC_AR934x
|
|
+ select ATH79_DEV_ETH
|
|
+ select ATH79_DEV_NFC
|
|
+ select ATH79_DEV_WMAC
|
|
+ select ATH79_DEV_USB
|
|
+ select ATH79_ROUTERBOOT
|
|
+ select RLE_DECOMPRESS
|
|
+
|
|
config ATH79_MACH_RB2011
|
|
bool "MikroTik RouterBOARD 2011 support"
|
|
select SOC_AR934x
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -71,6 +71,7 @@ obj-$(CONFIG_ATH79_MACH_PB44) += mach-p
|
|
obj-$(CONFIG_ATH79_MACH_PB92) += mach-pb92.o
|
|
obj-$(CONFIG_ATH79_MACH_RB4XX) += mach-rb4xx.o
|
|
obj-$(CONFIG_ATH79_MACH_RB750) += mach-rb750.o
|
|
+obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
|
|
obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
|
|
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
|
|
obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
|
|
--- a/arch/mips/ath79/prom.c
|
|
+++ b/arch/mips/ath79/prom.c
|
|
@@ -182,6 +182,7 @@ void __init prom_init(void)
|
|
}
|
|
|
|
if (strstr(arcs_cmdline, "board=750Gr3") ||
|
|
+ strstr(arcs_cmdline, "board=951G") ||
|
|
strstr(arcs_cmdline, "board=2011L"))
|
|
ath79_prom_append_cmdline("console", "ttyS0,115200");
|
|
}
|