bff468813f
- Includes large parts of the patch from #1021 by dpalffy - Includes RB532 NAND driver changes by n0-1 SVN-Revision: 5789
14 lines
516 B
Diff
14 lines
516 B
Diff
diff -urN linux-2.6.19.old/Makefile linux-2.6.19.dev/Makefile
|
|
--- linux-2.6.19.old/Makefile 2006-11-29 22:57:37.000000000 +0100
|
|
+++ linux-2.6.19.dev/Makefile 2006-12-14 03:13:23.000000000 +0100
|
|
@@ -513,6 +513,9 @@
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|