8dbed04ec9
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35055
29 lines
877 B
Diff
29 lines
877 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -561,4 +561,8 @@ config LEDS_TRIGGER_TRANSIENT
|
|
GPIO/PWM based hardware.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_MORSE
|
|
+ tristate "LED Morse Trigger"
|
|
+ depends on LEDS_TRIGGERS
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
|
|
obj-$(CONFIG_LEDS_TRIGGER_CPU) += ledtrig-cpu.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
--- a/drivers/leds/ledtrig-morse.c
|
|
+++ b/drivers/leds/ledtrig-morse.c
|
|
@@ -26,7 +26,6 @@
|
|
#include <linux/list.h>
|
|
#include <linux/spinlock.h>
|
|
#include <linux/device.h>
|
|
-#include <linux/sysdev.h>
|
|
#include <linux/timer.h>
|
|
#include <linux/ctype.h>
|
|
#include <linux/leds.h>
|