bdb1ee51f8
Fix locking and lock usage, making it compile for SMP. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43578
59 lines
2.1 KiB
Diff
59 lines
2.1 KiB
Diff
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
|
- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
+ lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
(rm -f $@ ; false)
|
|
|
|
quiet_cmd_lzo = LZO $@
|
|
--- a/scripts/gen_initramfs_list.sh
|
|
+++ b/scripts/gen_initramfs_list.sh
|
|
@@ -226,7 +226,7 @@ cpio_list=
|
|
output="/dev/stdout"
|
|
output_file=""
|
|
is_cpio_compressed=
|
|
-compr="gzip -n -9 -f"
|
|
+compr="gzip -n -9 -f -"
|
|
|
|
arg="$1"
|
|
case "$arg" in
|
|
@@ -242,13 +242,13 @@ case "$arg" in
|
|
output=${cpio_list}
|
|
echo "$output_file" | grep -q "\.gz$" \
|
|
&& [ -x "`which gzip 2> /dev/null`" ] \
|
|
- && compr="gzip -n -9 -f"
|
|
+ && compr="gzip -n -9 -f -"
|
|
echo "$output_file" | grep -q "\.bz2$" \
|
|
&& [ -x "`which bzip2 2> /dev/null`" ] \
|
|
- && compr="bzip2 -9 -f"
|
|
+ && compr="bzip2 -9 -f -"
|
|
echo "$output_file" | grep -q "\.lzma$" \
|
|
&& [ -x "`which lzma 2> /dev/null`" ] \
|
|
- && compr="lzma -9 -f"
|
|
+ && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
|
|
echo "$output_file" | grep -q "\.xz$" \
|
|
&& [ -x "`which xz 2> /dev/null`" ] \
|
|
&& compr="xz --check=crc32 --lzma2=dict=1MiB"
|
|
@@ -315,7 +315,7 @@ if [ ! -z ${output_file} ]; then
|
|
if [ "${is_cpio_compressed}" = "compressed" ]; then
|
|
cat ${cpio_tfile} > ${output_file}
|
|
else
|
|
- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
|
|
+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
|
|
|| (rm -f ${output_file} ; false)
|
|
fi
|
|
[ -z ${cpio_file} ] && rm ${cpio_tfile}
|
|
--- a/lib/decompress.c
|
|
+++ b/lib/decompress.c
|
|
@@ -48,6 +48,7 @@ static const struct compress_format comp
|
|
{ {037, 0236}, "gzip", gunzip },
|
|
{ {0x42, 0x5a}, "bzip2", bunzip2 },
|
|
{ {0x5d, 0x00}, "lzma", unlzma },
|
|
+ { {0x6d, 0x00}, "lzma-openwrt", unlzma },
|
|
{ {0xfd, 0x37}, "xz", unxz },
|
|
{ {0x89, 0x4c}, "lzo", unlzo },
|
|
{ {0x02, 0x21}, "lz4", unlz4 },
|