a1f4a43cef
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 40344
79 lines
2.1 KiB
Diff
79 lines
2.1 KiB
Diff
From 1f3e1c682a0b5273e3ee8799b54319971f426e6a Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
|
Date: Wed, 29 Jan 2014 18:06:52 +0100
|
|
Subject: [RFC V2][PATCH] MIPS: BCM47XX: Add new file for device specific workarounds
|
|
|
|
---
|
|
V2: Drop pr_debug for devices we don't need workarounds for. It was too
|
|
load and not useful at all.
|
|
---
|
|
arch/mips/bcm47xx/Makefile | 2 +-
|
|
arch/mips/bcm47xx/bcm47xx_private.h | 3 +++
|
|
arch/mips/bcm47xx/setup.c | 1 +
|
|
arch/mips/bcm47xx/workarounds.c | 25 +++++++++++++++++++++++++
|
|
4 files changed, 30 insertions(+), 1 deletion(-)
|
|
create mode 100644 arch/mips/bcm47xx/workarounds.c
|
|
|
|
--- a/arch/mips/bcm47xx/Makefile
|
|
+++ b/arch/mips/bcm47xx/Makefile
|
|
@@ -4,4 +4,4 @@
|
|
#
|
|
|
|
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
|
|
-obj-y += board.o buttons.o leds.o
|
|
+obj-y += board.o buttons.o leds.o workarounds.o
|
|
--- a/arch/mips/bcm47xx/bcm47xx_private.h
|
|
+++ b/arch/mips/bcm47xx/bcm47xx_private.h
|
|
@@ -9,4 +9,7 @@ int __init bcm47xx_buttons_register(void
|
|
/* leds.c */
|
|
void __init bcm47xx_leds_register(void);
|
|
|
|
+/* workarounds.c */
|
|
+void __init bcm47xx_workarounds(void);
|
|
+
|
|
#endif
|
|
--- a/arch/mips/bcm47xx/setup.c
|
|
+++ b/arch/mips/bcm47xx/setup.c
|
|
@@ -282,6 +282,7 @@ static int __init bcm47xx_register_bus_c
|
|
}
|
|
bcm47xx_buttons_register();
|
|
bcm47xx_leds_register();
|
|
+ bcm47xx_workarounds();
|
|
|
|
fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status);
|
|
return 0;
|
|
--- /dev/null
|
|
+++ b/arch/mips/bcm47xx/workarounds.c
|
|
@@ -0,0 +1,31 @@
|
|
+#include "bcm47xx_private.h"
|
|
+
|
|
+#include <linux/gpio.h>
|
|
+#include <bcm47xx_board.h>
|
|
+#include <bcm47xx.h>
|
|
+
|
|
+static void __init bcm47xx_workarounds_netgear_wnr3500l(void)
|
|
+{
|
|
+ const int usb_power = 12;
|
|
+ int err;
|
|
+
|
|
+ err = gpio_request_one(usb_power, GPIOF_OUT_INIT_HIGH, "usb_power");
|
|
+ if (err)
|
|
+ pr_err("Failed to request USB power gpio: %d\n", err);
|
|
+ else
|
|
+ gpio_free(usb_power);
|
|
+}
|
|
+
|
|
+void __init bcm47xx_workarounds(void)
|
|
+{
|
|
+ enum bcm47xx_board board = bcm47xx_board_get();
|
|
+
|
|
+ switch (board) {
|
|
+ case BCM47XX_BOARD_NETGEAR_WNR3500L:
|
|
+ bcm47xx_workarounds_netgear_wnr3500l();
|
|
+ break;
|
|
+ default:
|
|
+ /* No workaround(s) needed */
|
|
+ break;
|
|
+ }
|
|
+}
|