72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
80 lines
3.0 KiB
Diff
80 lines
3.0 KiB
Diff
Index: linux-3.18-rc4/arch/arm/Kconfig
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/arch/arm/Kconfig
|
|
+++ linux-3.18-rc4/arch/arm/Kconfig
|
|
@@ -369,6 +369,17 @@ config ARCH_VERSATILE
|
|
help
|
|
This enables support for ARM Ltd Versatile board.
|
|
|
|
+config ARCH_OXNAS
|
|
+ bool "Oxford Semiconductor 815/820/825 NAS SoC"
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select CLKDEV_LOOKUP
|
|
+ select GENERIC_CLOCKEVENTS
|
|
+ select COMMON_CLK
|
|
+ select MIGHT_HAVE_PCI
|
|
+ select ARCH_HAS_RESET_CONTROLLER
|
|
+ help
|
|
+ This enables support for Oxsemi 815/820/825 NAS SoC
|
|
+
|
|
config ARCH_AT91
|
|
bool "Atmel AT91"
|
|
select ARCH_REQUIRE_GPIOLIB
|
|
@@ -922,6 +933,8 @@ source "arch/arm/mach-omap2/Kconfig"
|
|
|
|
source "arch/arm/mach-orion5x/Kconfig"
|
|
|
|
+source "arch/arm/mach-oxnas/Kconfig"
|
|
+
|
|
source "arch/arm/mach-picoxcell/Kconfig"
|
|
|
|
source "arch/arm/mach-pxa/Kconfig"
|
|
Index: linux-3.18-rc4/arch/arm/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/arch/arm/Makefile
|
|
+++ linux-3.18-rc4/arch/arm/Makefile
|
|
@@ -187,6 +187,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
|
|
machine-$(CONFIG_ARCH_OMAP1) += omap1
|
|
machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
|
|
machine-$(CONFIG_ARCH_ORION5X) += orion5x
|
|
+machine-$(CONFIG_ARCH_OXNAS) += oxnas
|
|
machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
|
|
machine-$(CONFIG_ARCH_PXA) += pxa
|
|
machine-$(CONFIG_ARCH_QCOM) += qcom
|
|
Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
|
|
+++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
|
|
@@ -352,6 +352,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
|
|
orion5x-lacie-ethernet-disk-mini-v2.dtb \
|
|
orion5x-maxtor-shared-storage-2.dtb \
|
|
orion5x-rd88f5182-nas.dtb
|
|
+dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
|
|
dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
|
|
dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8064-cm-qs600.dtb \
|
|
Index: linux-3.18-rc4/arch/arm/tools/mach-types
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/arch/arm/tools/mach-types
|
|
+++ linux-3.18-rc4/arch/arm/tools/mach-types
|
|
@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
|
|
edb9307a MACH_EDB9307A EDB9307A 1128
|
|
omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
|
|
vstms MACH_VSTMS VSTMS 1140
|
|
+ox820 MACH_OX820 OX820 1152
|
|
micro9m MACH_MICRO9M MICRO9M 1169
|
|
bug MACH_BUG BUG 1179
|
|
at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
|
|
Index: linux-3.18-rc4/drivers/clk/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/clk/Makefile
|
|
+++ linux-3.18-rc4/drivers/clk/Makefile
|
|
@@ -29,6 +29,7 @@ obj-$(CONFIG_COMMON_CLK_MAX77802) += clk
|
|
obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
|
|
obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o
|
|
obj-$(CONFIG_ARCH_NSPIRE) += clk-nspire.o
|
|
+obj-$(CONFIG_ARCH_OXNAS) += clk-oxnas.o
|
|
obj-$(CONFIG_COMMON_CLK_PALMAS) += clk-palmas.o
|
|
obj-$(CONFIG_CLK_PPC_CORENET) += clk-ppc-corenet.o
|
|
obj-$(CONFIG_COMMON_CLK_RK808) += clk-rk808.o
|