e5a65db1b5
CFI detection will reduce the resource size to its real value. Patch from Daniel Gimpelevich. SVN-Revision: 33752
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
--- a/drivers/mtd/maps/physmap.c
|
|
+++ b/drivers/mtd/maps/physmap.c
|
|
@@ -78,7 +78,7 @@ static const char *rom_probe_types[] = {
|
|
"map_rom",
|
|
NULL };
|
|
static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
|
|
- NULL };
|
|
+ "ar7part", NULL };
|
|
|
|
static int physmap_flash_probe(struct platform_device *dev)
|
|
{
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|
|
--- a/arch/mips/ar7/platform.c
|
|
+++ b/arch/mips/ar7/platform.c
|
|
@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
|
|
.name = "mem",
|
|
.flags = IORESOURCE_MEM,
|
|
.start = 0x10000000,
|
|
- .end = 0x107fffff,
|
|
+ .end = 0x11ffffff,
|
|
};
|
|
|
|
static struct physmap_flash_data physmap_flash_data = {
|