3534e26463
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 43443
105 lines
2.3 KiB
Diff
105 lines
2.3 KiB
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -798,7 +798,6 @@ AC_ARG_ENABLE([libmount],
|
|
)
|
|
UL_BUILD_INIT([libmount])
|
|
UL_REQUIRES_BUILD([libmount], [libblkid])
|
|
-UL_REQUIRES_HAVE([libmount], [scanf_alloc_modifier], [scanf string alloc modifier])
|
|
AM_CONDITIONAL([BUILD_LIBMOUNT], [test "x$build_libmount" = xyes])
|
|
AM_CONDITIONAL([BUILD_LIBMOUNT_TESTS], [test "x$build_libmount" = xyes -a "x$enable_static" = xyes])
|
|
|
|
--- a/libmount/src/tab_parse.c
|
|
+++ b/libmount/src/tab_parse.c
|
|
@@ -22,6 +22,10 @@
|
|
#include "pathnames.h"
|
|
#include "strutils.h"
|
|
|
|
+#ifndef HAVE_SCANF_MS_MODIFIER
|
|
+# define UL_SCNsA "%s"
|
|
+#endif
|
|
+
|
|
static int next_number(char **s, int *num)
|
|
{
|
|
char *end = NULL;
|
|
@@ -52,16 +56,31 @@ static int mnt_parse_table_line(struct l
|
|
int rc, n = 0, xrc;
|
|
char *src = NULL, *fstype = NULL, *optstr = NULL;
|
|
|
|
+#ifndef HAVE_SCANF_MS_MODIFIER
|
|
+ size_t len = strlen(s) + 1;
|
|
+ src = malloc(len);
|
|
+ fstype = malloc(len);
|
|
+ fs->target = malloc(len);
|
|
+ optstr = malloc(len);
|
|
+#endif
|
|
+
|
|
rc = sscanf(s, UL_SCNsA" " /* (1) source */
|
|
UL_SCNsA" " /* (2) target */
|
|
UL_SCNsA" " /* (3) FS type */
|
|
UL_SCNsA" " /* (4) options */
|
|
"%n", /* byte count */
|
|
|
|
+#ifdef HAVE_SCANF_MS_MODIFIER
|
|
&src,
|
|
&fs->target,
|
|
&fstype,
|
|
&optstr,
|
|
+#else
|
|
+ src,
|
|
+ fs->target,
|
|
+ fstype,
|
|
+ optstr,
|
|
+#endif
|
|
&n);
|
|
xrc = rc;
|
|
|
|
@@ -127,6 +146,16 @@ static int mnt_parse_mountinfo_line(stru
|
|
unsigned int maj, min;
|
|
char *fstype = NULL, *src = NULL, *p;
|
|
|
|
+#ifndef HAVE_SCANF_MS_MODIFIER
|
|
+ size_t len = strlen(s) + 1;
|
|
+ fs->root = malloc(len);
|
|
+ fs->target = malloc(len);
|
|
+ fs->vfs_optstr = malloc(len);
|
|
+ fs->fs_optstr = malloc(len);
|
|
+ fstype = malloc(len);
|
|
+ src = malloc(len);
|
|
+#endif
|
|
+
|
|
rc = sscanf(s, "%d " /* (1) id */
|
|
"%d " /* (2) parent */
|
|
"%u:%u " /* (3) maj:min */
|
|
@@ -138,9 +167,15 @@ static int mnt_parse_mountinfo_line(stru
|
|
&fs->id,
|
|
&fs->parent,
|
|
&maj, &min,
|
|
+#ifdef HAVE_SCANF_MS_MODIFIER
|
|
&fs->root,
|
|
&fs->target,
|
|
&fs->vfs_optstr,
|
|
+#else
|
|
+ fs->root,
|
|
+ fs->target,
|
|
+ fs->vfs_optstr,
|
|
+#endif
|
|
&end);
|
|
|
|
if (rc >= 7 && end > 0)
|
|
@@ -160,9 +195,15 @@ static int mnt_parse_mountinfo_line(stru
|
|
UL_SCNsA" " /* (9) source */
|
|
UL_SCNsA, /* (10) fs options (fs specific) */
|
|
|
|
+#ifdef HAVE_SCANF_MS_MODIFIER
|
|
&fstype,
|
|
&src,
|
|
&fs->fs_optstr);
|
|
+#else
|
|
+ fstype,
|
|
+ src,
|
|
+ fs->fs_optstr);
|
|
+#endif
|
|
|
|
if (rc >= 10) {
|
|
size_t sz;
|