72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
Index: linux-3.18-rc4/drivers/mtd/nand/Kconfig
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/mtd/nand/Kconfig
|
|
+++ linux-3.18-rc4/drivers/mtd/nand/Kconfig
|
|
@@ -516,4 +516,12 @@ config MTD_NAND_XWAY
|
|
Enables support for NAND Flash chips on Lantiq XWAY SoCs. NAND is attached
|
|
to the External Bus Unit (EBU).
|
|
|
|
+config MTD_NAND_OXNAS
|
|
+ tristate "Support for NAND on Plxtech NAS782X SoC"
|
|
+ depends on ARCH_OXNAS
|
|
+ select MTD_NAND_PLATFORM
|
|
+ help
|
|
+ Enables support for NAND Flash chips on Plxtech NAS782X SoCs. NAND is attached
|
|
+ to the STATIC Unit.
|
|
+
|
|
endif # MTD_NAND
|
|
Index: linux-3.18-rc4/drivers/mtd/nand/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/mtd/nand/Makefile
|
|
+++ linux-3.18-rc4/drivers/mtd/nand/Makefile
|
|
@@ -50,5 +50,6 @@ obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740
|
|
obj-$(CONFIG_MTD_NAND_GPMI_NAND) += gpmi-nand/
|
|
obj-$(CONFIG_MTD_NAND_XWAY) += xway_nand.o
|
|
obj-$(CONFIG_MTD_NAND_BCM47XXNFLASH) += bcm47xxnflash/
|
|
+obj-$(CONFIG_MTD_NAND_OXNAS) += oxnas_nand.o
|
|
|
|
nand-objs := nand_base.o nand_bbt.o nand_timings.o
|