0f1522cf59
SVN-Revision: 20418
68 lines
2.2 KiB
Diff
68 lines
2.2 KiB
Diff
Index: linux-2.6.30.10/arch/mips/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.30.10.orig/arch/mips/Kconfig 2010-03-24 15:32:02.000000000 +0100
|
|
+++ linux-2.6.30.10/arch/mips/Kconfig 2010-03-24 21:56:29.000000000 +0100
|
|
@@ -79,6 +79,23 @@
|
|
select SYS_SUPPORTS_64BIT_KERNEL
|
|
select SYS_SUPPORTS_LITTLE_ENDIAN
|
|
|
|
+config IFXMIPS
|
|
+ bool "Infineon Twinpass, Danube, Amazon-SE"
|
|
+ select DMA_NONCOHERENT
|
|
+ select IRQ_CPU
|
|
+ select CEVT_R4K
|
|
+ select CSRC_R4K
|
|
+ select SYS_HAS_CPU_MIPS32_R1
|
|
+ select SYS_HAS_CPU_MIPS32_R2
|
|
+ select HAVE_STD_PC_SERIAL_PORT
|
|
+ select SYS_SUPPORTS_BIG_ENDIAN
|
|
+ select SYS_SUPPORTS_32BIT_KERNEL
|
|
+ select SYS_SUPPORTS_MULTITHREADING
|
|
+ select SYS_HAS_EARLY_PRINTK
|
|
+ select HW_HAS_PCI
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select SWAP_IO_SPACE
|
|
+
|
|
config MACH_DECSTATION
|
|
bool "DECstations"
|
|
select BOOT_ELF32
|
|
@@ -643,6 +660,7 @@
|
|
source "arch/mips/txx9/Kconfig"
|
|
source "arch/mips/vr41xx/Kconfig"
|
|
source "arch/mips/cavium-octeon/Kconfig"
|
|
+source "arch/mips/ifxmips/Kconfig"
|
|
|
|
endmenu
|
|
|
|
Index: linux-2.6.30.10/arch/mips/Makefile
|
|
===================================================================
|
|
--- linux-2.6.30.10.orig/arch/mips/Makefile 2010-03-24 15:32:02.000000000 +0100
|
|
+++ linux-2.6.30.10/arch/mips/Makefile 2010-03-24 15:32:04.000000000 +0100
|
|
@@ -290,6 +290,13 @@
|
|
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
|
|
|
#
|
|
+# Infineon IFXMIPS
|
|
+#
|
|
+core-$(CONFIG_IFXMIPS) += arch/mips/ifxmips/
|
|
+cflags-$(CONFIG_IFXMIPS) += -I$(srctree)/arch/mips/include/asm/mach-ifxmips
|
|
+load-$(CONFIG_IFXMIPS) += 0xffffffff80002000
|
|
+
|
|
+#
|
|
# DECstation family
|
|
#
|
|
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
|
|
Index: linux-2.6.30.10/arch/mips/include/asm/bootinfo.h
|
|
===================================================================
|
|
--- linux-2.6.30.10.orig/arch/mips/include/asm/bootinfo.h 2009-12-04 07:00:07.000000000 +0100
|
|
+++ linux-2.6.30.10/arch/mips/include/asm/bootinfo.h 2010-03-24 15:32:04.000000000 +0100
|
|
@@ -57,6 +57,8 @@
|
|
#define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
|
|
#define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
|
|
|
|
+#define MACH_INFINEON_IFXMIPS 0
|
|
+
|
|
#define CL_SIZE COMMAND_LINE_SIZE
|
|
|
|
extern char *system_type;
|