dcae3ef009
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38932
58 lines
2.2 KiB
Diff
58 lines
2.2 KiB
Diff
From patchwork Thu Aug 29 23:27:52 2013
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [2/3] crypto: omap-des: Add config and build options
|
|
From: Joel Fernandes <joelf@ti.com>
|
|
X-Patchwork-Id: 2851671
|
|
Message-Id: <1377818873-21174-3-git-send-email-joelf@ti.com>
|
|
To: Herbert Xu <herbert@gondor.hengli.com.au>, "David S. Miller"
|
|
<davem@davemloft.net>, Mark Greer <mgreer@animalcreek.com>, Tony Lindgren
|
|
<tony@atomide.com>, Lokesh Vutla <lokeshvutla@ti.com>
|
|
Cc: Joel Fernandes <joelf@ti.com>,
|
|
Linux OMAP List <linux-omap@vger.kernel.org>,
|
|
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
|
|
Linux ARM Kernel List <linux-arm-kernel@lists.infradead.org>,
|
|
Linux Crypto Mailing List <linux-crypto@vger.kernel.org>
|
|
Date: Thu, 29 Aug 2013 18:27:52 -0500
|
|
|
|
Add config and build options for the newly added omap-des driver.
|
|
|
|
Signed-off-by: Joel Fernandes <joelf@ti.com>
|
|
|
|
---
|
|
drivers/crypto/Kconfig | 11 +++++++++++
|
|
drivers/crypto/Makefile | 1 +
|
|
2 files changed, 12 insertions(+)
|
|
|
|
--- a/drivers/crypto/Kconfig
|
|
+++ b/drivers/crypto/Kconfig
|
|
@@ -263,6 +263,17 @@ config CRYPTO_DEV_OMAP_AES
|
|
OMAP processors have AES module accelerator. Select this if you
|
|
want to use the OMAP module for AES algorithms.
|
|
|
|
+config CRYPTO_DEV_OMAP_DES
|
|
+ tristate "Support for OMAP DES3DES hw engine"
|
|
+ depends on ARCH_OMAP2PLUS
|
|
+ select CRYPTO_DES
|
|
+ select CRYPTO_BLKCIPHER2
|
|
+ help
|
|
+ OMAP processors have DES/3DES module accelerator. Select this if you
|
|
+ want to use the OMAP module for DES and 3DES algorithms. Currently
|
|
+ the ECB and CBC modes of operation supported by the driver. Also
|
|
+ accesses made on unaligned boundaries are also supported.
|
|
+
|
|
config CRYPTO_DEV_PICOXCELL
|
|
tristate "Support for picoXcell IPSEC and Layer2 crypto engines"
|
|
depends on ARCH_PICOXCELL && HAVE_CLK
|
|
--- a/drivers/crypto/Makefile
|
|
+++ b/drivers/crypto/Makefile
|
|
@@ -11,6 +11,7 @@ obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4x
|
|
obj-$(CONFIG_CRYPTO_DEV_PPC4XX) += amcc/
|
|
obj-$(CONFIG_CRYPTO_DEV_OMAP_SHAM) += omap-sham.o
|
|
obj-$(CONFIG_CRYPTO_DEV_OMAP_AES) += omap-aes.o
|
|
+obj-$(CONFIG_CRYPTO_DEV_OMAP_DES) += omap-des.o
|
|
obj-$(CONFIG_CRYPTO_DEV_PICOXCELL) += picoxcell_crypto.o
|
|
obj-$(CONFIG_CRYPTO_DEV_SAHARA) += sahara.o
|
|
obj-$(CONFIG_CRYPTO_DEV_DCP) += dcp.o
|